Last Comment Bug 662500 - Drop pref that forces OOP tabs
: Drop pref that forces OOP tabs
Status: RESOLVED FIXED
[e10s]
:
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: unspecified
: x86 All
: -- normal (vote)
: mozilla8
Assigned To: :Felipe Gomes (needinfo me!)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-07 02:58 PDT by :Felipe Gomes (needinfo me!)
Modified: 2013-04-29 06:24 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (3.57 KB, patch)
2011-06-07 02:58 PDT, :Felipe Gomes (needinfo me!)
benjamin: review+
Details | Diff | Review

Description :Felipe Gomes (needinfo me!) 2011-06-07 02:58:26 PDT
Created attachment 537762 [details] [diff] [review]
Patch

A pref that forces oop tabs only breaks stuff (no code that is not expecting remote browsers will handle it correctly) and will never be supported, so we should drop it from the code. 

Also, I'd like to reuse this pref name as the pref that will switch the front end to use remote browsers, to nicely match the force-disable "dom.ipc.tabs.disabled" pref.
(any objections? dom.ipc.tabs.disabled is from libpref but dom.ipc.tabs.enabled will be in browser)

Every host app who wants to request remote browsers should use the remote="true" attribute.

(I made the changes in fennec-tile-testapp for correctness, but I don't think that's used anymore..)
Comment 1 :Felipe Gomes (needinfo me!) 2011-06-07 03:14:38 PDT
oh actually dom.ipc.tabs.disabled is not from libpref, it's not defined anywhere.. even better
Comment 2 :Felipe Gomes (needinfo me!) 2011-06-07 13:59:30 PDT
http://hg.mozilla.org/projects/electrolysis/rev/c68fab138909
Comment 3 Marco Bonardo [::mak] 2011-07-01 07:47:28 PDT
I backed out everything from central since Android and Maemo were unhappy about the push these changes were part of.
Comment 4 :Felipe Gomes (needinfo me!) 2011-07-08 13:10:41 PDT
http://hg.mozilla.org/mozilla-central/rev/faae99972d35

Note You need to log in before you can comment on or make changes to this bug.