Last Comment Bug 662534 - Let imgRequestProxy implement nsITimedChannel, collect telemetry
: Let imgRequestProxy implement nsITimedChannel, collect telemetry
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: All All
: -- enhancement (vote)
: mozilla7
Assigned To: Honza Bambas (:mayhemer)
:
Mentors:
Depends on:
Blocks: 658894
  Show dependency treegraph
 
Reported: 2011-06-07 08:01 PDT by Honza Bambas (:mayhemer)
Modified: 2011-06-10 02:55 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (6.64 KB, patch)
2011-06-09 05:16 PDT, Honza Bambas (:mayhemer)
joe: review+
Details | Diff | Review

Description Honza Bambas (:mayhemer) 2011-06-07 08:01:41 PDT
In bug 658894 we collect some basic telemetry for a page load and its subrequests.  However, image requests are not included because imgRequetsProxy doesn't implement the new nsITimedChannel interface.

I have a patch for that already, will submit that for review after it passes try.
Comment 1 Honza Bambas (:mayhemer) 2011-06-09 05:16:16 PDT
Created attachment 538239 [details] [diff] [review]
v1
Comment 2 Joe Drew (not getting mail) 2011-06-09 11:45:04 PDT
Comment on attachment 538239 [details] [diff] [review]
v1

Review of attachment 538239 [details] [diff] [review]:
-----------------------------------------------------------------

::: modules/libpr0n/src/imgRequestProxy.h
@@ +82,5 @@
>    NS_DECL_IMGIREQUEST
>    NS_DECL_NSIREQUEST
>    NS_DECL_NSISUPPORTSPRIORITY
>    NS_DECL_NSISECURITYINFOPROVIDER
> +  // nsITimedChannel declared bellow

"below"
Comment 3 Honza Bambas (:mayhemer) 2011-06-09 14:16:12 PDT
Landed as http://hg.mozilla.org/integration/mozilla-inbound/rev/c023a6a059d1
Comment 4 Mounir Lamouri (:mounir) 2011-06-10 02:55:39 PDT
http://hg.mozilla.org/mozilla-central/rev/c023a6a059d1

Note You need to log in before you can comment on or make changes to this bug.