Closed Bug 662567 Opened 10 years ago Closed 3 years ago

Show Sync discoverability billboards again after deactivating Sync account

Categories

(Firefox :: Sync, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: tchung, Unassigned)

References

Details

i'm told this is by design, so i'll file as a enhancement.

If i remove an existing sync account from my client (deactivate this account through sync prefs), the sync discoverability billboards no longer appear.   The current logic argues that a user that has previously set one up, should not need to be nagged on setting it up again.   I'd argue though, that there can be corner cases where i hand my machine to another user after i exit my sync account, and they may never discover it.  Another case could be i have firefox open for a long period of time, had disconnected sync awhile back after trying it out, but at least should get another reminder to give it a shot again.   Out of sight, out of mind is the case here, and if we're trying to be more discoverable, why not show it all the time if you're not connected to sync?

There was discussion that this is bad UX to have annoying popup of the billboard, but the current design in the bookmark billboard and password manager reminder doesnt not seem obtrusive to me at all.

Repro:
1) install nightly firefox: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0a1) Gecko/20110607 Firefox/7.0a1
2) connect to sync, then deactivate your sync account through sync prefs
3) click bookmark star icon or remember passwords dialog
4) verify the sync discoverability billboards no longer appear since i had a previous sync account connected:

Expected:
- show the billboards if sync is not connected

Actual:
- no billboards after disconnecting.
basically, "reset" browser.syncPromoViewsLeft
Sync discoverability billboards are no longer a thing.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.