browser crashed if I save image on dynamicly created page

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: mikey, Assigned: vishy)

Tracking

({crash})

Trunk
x86
Windows 98
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; 0.7) Gecko/20010109
BuildID:    2001010901

When I choose Save Image from pop-up menu (right click on image) on this url:
www.linux.co.yu/ my all browser's opened windows crashed and I need to load
Mozilla browser again in memory.

Reproducible: Always
Steps to Reproduce:
Go to url: www.linux.co.yu
On down right side of page yuo can see a image.
Above of image is a text "Slika dana".
Click on small image to get it full size version.
In new opened window image will be loaded.
Click with right click on image to open menu.
Choose save image...
Mozilla browser then crashed and all opened browser windows crashed instead save
dialog window to be opened.

Actual Results:  I have not Mozilla started in memory of my computer.

Expected Results:  To save image on my hard disk.

Image which is shown on this page is dynamicly created from MySQL databese using
PHP. Other images are saved correctly.

Comment 1

18 years ago
Crashed here too.
Mozilla 2001012120 on Windows 2000 SP1 on PC.
I wil try with the latest build and comment again.

Comment 2

18 years ago
Tried with 2001012220 and it crashed too.
Changed component to XP Apps.
Assignee: asa → vishy
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps
Ever confirmed: true
QA Contact: doronr → sairuh
The window in question has a onblur="self.close()" attribute on the body tag. 
This gets called whenever the filepicker comes up, since the filepicker takes focus.

I've been unable to get a debug build (from around 11pm EST on 2001-01-22) to
crash, but I get the following messages in the console every time I try to
reproduce:

###!!! ASSERTION: No 'Components' in scope!: '0', file
xpcwrappednativescope.cpp, line 156
###!!! Break: at file xpcwrappednativescope.cpp, line 156
JavaScript error: 
chrome://communicator/content/nsContextMenu.js line 823: 

This could be a duplicate of bug 62643.  If so, it may also be fixed by the
checkin that fixes bug 65243, which went in on the evening of the 22nd (and may
not have made it into the 2001-01-22-20 builds)
odd, i cannot get this to crash, using 2001.01.23.04 verif [commercial] bits on
linux and winNT. then again, when i click the small image, the new browser
window that opens only briefly flashes a larger version of the image, only to be
repainted with the content of the original browser window. *shrug*

as a twist, i tried just right-clicking the small image: what i got was the save
dialog [file picker] *as well as* a new browser window. the save dialog seemed
modal, but i could save the image, the return to browser windows with no other
problems...
Keywords: crash

Comment 5

18 years ago
###!!! ASSERTION: No 'Components' in scope!: '0', file

is bug 54461. I don't think however this is the cause of (or even related to)
the crash.

Comment 6

18 years ago
Tested on linux.  I blame the content here, image loads in
new window, and as soon as there's mouse movement the window
swaps the image with the HTML content.  I can save the image
fine w/o loading it in a new window.  Marking WFM based on
earlier comments in this bug.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
mass verification of WorksForMe bugs: to find all bugspam pertaining to this,
set your search string to "IfItWorksForSlappyTheSquirrelThenItWFM".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. that it's still a problem with ***recent trunk builds*** on the all
appropriate platform[s]

b. provide clear steps to reproduce (unless a good test case is already in the
bug report), making sure it pertains to the original problem (avoid morphing as
much as possible :)
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.