Last Comment Bug 662766 - parseInt fast path should return integers instead of doubles
: parseInt fast path should return integers instead of doubles
Status: RESOLVED FIXED
: perf
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem] (PTO until July 31)
:
Mentors:
Depends on:
Blocks: 652303
  Show dependency treegraph
 
Reported: 2011-06-08 04:16 PDT by Jan de Mooij [:jandem] (PTO until July 31)
Modified: 2011-06-08 11:15 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.13 KB, patch)
2011-06-08 04:41 PDT, Jan de Mooij [:jandem] (PTO until July 31)
bhackett1024: review+
Details | Diff | Splinter Review
Patch (4.54 KB, patch)
2011-06-08 10:59 PDT, Jan de Mooij [:jandem] (PTO until July 31)
bhackett1024: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] (PTO until July 31) 2011-06-08 04:16:47 PDT
Many inline paths don't handle doubles so this can cause large performance problems. The TI branch had a fix for this but it regressed again, probably after merging bug 653153.
Comment 1 Jan de Mooij [:jandem] (PTO until July 31) 2011-06-08 04:41:59 PDT
Created attachment 537984 [details] [diff] [review]
Patch

Strictly speaking this is not a TI bug, but since TI will merge soon I think we should fix it there to prevent merge problems.
Comment 2 Brian Hackett (:bhackett) 2011-06-08 06:54:25 PDT
Comment on attachment 537984 [details] [diff] [review]
Patch

setNumber returns whether the number is an int32 (JM branch only), so this can be simplified a bit.
Comment 3 Jan de Mooij [:jandem] (PTO until July 31) 2011-06-08 10:59:54 PDT
Created attachment 538063 [details] [diff] [review]
Patch

Rewrote some other calls that use the same setNumber pattern.
Comment 4 Brian Hackett (:bhackett) 2011-06-08 11:01:56 PDT
Comment on attachment 538063 [details] [diff] [review]
Patch

Nice!
Comment 5 Jan de Mooij [:jandem] (PTO until July 31) 2011-06-08 11:15:37 PDT
http://hg.mozilla.org/projects/jaegermonkey/rev/73d2e2357b5b

Note You need to log in before you can comment on or make changes to this bug.