Closed Bug 662785 Opened 9 years ago Closed 9 years ago

AboutRedirector references about:firstrun module

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 7

People

(Reporter: aaronmt, Assigned: wesj)

References

Details

Attachments

(1 file)

Build Identifier: Mozilla/5.0 (Android; Linux armv7l; rv:7.0a1) Gecko/20110608 Firefox/7.0a1 Fennec/7.0a1

STR: about:firstrun
ER: "The URL is not valid and cannot be loaded."
AR: File not found for firstrun.xhtml

http://mxr.mozilla.org/mozilla-central/source/mobile/components/AboutRedirector.js#56
Attached patch PatchSplinter Review
Whoops. Found a few other references for bookmarks too.
Assignee: nobody → wjohnston
Attachment #538034 - Flags: review?(mark.finkle)
Attachment #538034 - Flags: review?(mark.finkle) → review+
Duplicate of this bug: 662862
One other spot about:firstrun is listed is in the listing in 'about:about'
Keywords: checkin-needed
Another reference is the default bookmark 'Firefox: Welcome' (about:firstrun).
(In reply to comment #4)
> Another reference is the default bookmark 'Firefox: Welcome'
> (about:firstrun).

comment #1, nm
Whiteboard: [inbound]
Status: NEW → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → Firefox 7
(In reply to comment #3)
> One other spot about:firstrun is listed is in the listing in 'about:about'

This is still listed.
(In reply to comment #7)
> (In reply to comment #3)
> > One other spot about:firstrun is listed is in the listing in 'about:about'
> 
> This is still listed.

nm, checked out a recent tbpl build
Pushed http://hg.mozilla.org/integration/mozilla-inbound/rev/82085960e9f1 to calm down some, but not quite all, of the orange.
Depends on: 663596
verified:

Mozilla/5.0 (Android; Linux armv71; rv7.0a1) Gecko/20110613 Firefox/7.0a1 Fennec/7.0a1
Device: Thunderbolt
OS: Android 2.2

Mozilla/5.0 (Android; Linux armv71; rv7.0a1) Gecko/20110613 Firefox/7.0a1 Fennec/7.0a1
Device: HTC Flyer
OS: Android 2.3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.