Using Tabs to Change Focus Doesn't Highlight Text

VERIFIED DUPLICATE of bug 28583

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 28583
18 years ago
14 years ago

People

(Reporter: C.S. Mo, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When you use the tab key to change focus from one field to another, particularly
in a form but also when tabbing into the search/URL bar, the current text is not
highlighted. In most non-Microsoft applications on the Mac, the default behavior
when tabbing is to highlight the text currently in the field.

Comment 1

18 years ago
Reporter please read, http://www.mozilla.org/quality/bug-writing-guidelines.html
and comment with some more information about the bug, including what Mozilla
build your using, and a testcase or example page where this happens. Thanks in
advance.
(Reporter)

Comment 2

18 years ago
The build is not really relevant as this applies to all builds. It is
reproducible on any page and is really a UI issue rather than a "bug".

It is basically an issue of whether or not you want to follow PC-style UI
conventions or MacOS-style UI conventions. On a Mac, when you tab into a
text-field, the text should be selected. On a PC this is generally not true.
However, if your software is going to run on a Mac, you should probably follow
MacOS conventions.

Comment 3

18 years ago
Moving to UI: Feedback and Marking NEW.
Status: UNCONFIRMED → NEW
Component: Browser-General → User Interface: Design Feedback
Ever confirmed: true

Comment 4

18 years ago
C.S.Mo is incorrect: on Windows the same behavior (selecting the widget 
contents) is expected. The only platform where it is not expected is X, where 
doing so would (unfortunately) mess with the X selection clipboard behavior.

*** This bug has been marked as a duplicate of 28583 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
OS: Mac System 9.x → All
Hardware: Macintosh → All
Resolution: --- → DUPLICATE

Comment 5

18 years ago
vrfy dupe of bug 28583
Focusing text widget (except on click) should select widget contents
Status: RESOLVED → VERIFIED

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.