Last Comment Bug 662898 - Canvas regression: Cannot draw image into canvas
: Canvas regression: Cannot draw image into canvas
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla7
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
:
Mentors:
http://radikalfx.com/files/collage/de...
: 667040 668742 (view as bug list)
Depends on:
Blocks: 639689
  Show dependency treegraph
 
Reported: 2011-06-08 12:30 PDT by Mark D.
Modified: 2011-08-31 05:41 PDT (History)
13 users (show)
roc: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
affected
-
fixed


Attachments
fix (1.64 KB, patch)
2011-06-08 22:14 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
jmuizelaar: review+
Details | Diff | Splinter Review
testcase (2.84 KB, patch)
2011-06-11 04:51 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
jmuizelaar: review+
Details | Diff | Splinter Review
fix test failure (1.69 KB, patch)
2011-06-12 18:40 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
bugzilla: approval‑mozilla‑aurora+
asa: approval‑mozilla‑beta-
Details | Diff | Splinter Review

Description Mark D. 2011-06-08 12:30:25 PDT
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0

Cannot get canvas from canvas A, and draw it as an image into canvas B.

Reproducible: Always

Steps to Reproduce:
1. Visit http://radikalfx.com/files/collage/demo.html
2. Click search button on the bottom left
3. Click on an image

Actual Results:  
Image is not loaded into the canvas, instead there is an empty rectangle

Expected Results:  
Image is loaded into the canvas

Does not work in Firefox 5, or Firefox 7.0a1.
Works in Firefox 4.0.1, Safari, and Google Chrome
Comment 1 Alice0775 White 2011-06-08 12:44:21 PDT
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/0798b52bb40d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110324 Firefox/4.2a1pre ID:20110324144234
Fails:
http://hg.mozilla.org/mozilla-central/rev/6a95db826e08
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110324 Firefox/4.2a1pre ID:20110324145508
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0798b52bb40d&tochange=6a95db826e08
Comment 2 Alice0775 White 2011-06-08 13:06:06 PDT
FYI,
Toggle shadow off, then the image appears,
Comment 3 Alice0775 White 2011-06-08 21:40:11 PDT
Bisected in local build,
Triggered by:
a34fe4ee349a	Robert O'Callahan — Bug 639689. Part 3: Remove unnecessary full context save/restore, and redundant SetPattern call. r=joe
Comment 4 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-08 22:14:22 PDT
Created attachment 538172 [details] [diff] [review]
fix
Comment 5 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-08 22:15:20 PDT
I'll write a test for this when my tree is in a better state.
Comment 6 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-11 04:51:49 PDT
Created attachment 538685 [details] [diff] [review]
testcase
Comment 7 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-11 04:58:36 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/e01a18d61dd6

Once this lands on central, I would like to get it into ff5/beta if possible.
Comment 8 Philipp von Weitershausen [:philikon] 2011-06-11 06:46:16 PDT
Backed out on m-i due to test_canvas.html failures:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3d1b0a500fbf
Comment 9 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-12 18:40:22 PDT
Created attachment 538795 [details] [diff] [review]
fix test failure

We need to make sure the input pattern is set correctly when we draw the shadow.
Comment 10 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-12 18:44:40 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/a858cef629f0
http://hg.mozilla.org/integration/mozilla-inbound/rev/70c1c696f691

I pushed the test on the assumption it will be OK. If Jeff doesn't like it we can change it later.
Comment 12 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-13 03:23:49 PDT
Comment on attachment 538795 [details] [diff] [review]
fix test failure

Probably too late for beta, but might as well draw the attention of release drivers.

This is a canvas regression in an edge case, but the fix is very simple.
Comment 13 Asa Dotzler [:asa] 2011-06-13 14:26:49 PDT
Comment on attachment 538795 [details] [diff] [review]
fix test failure

too late for beta. we'll evaluate for 6.
Comment 14 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-16 20:53:50 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/e160897167a6
http://hg.mozilla.org/releases/mozilla-aurora/rev/3a6e0d66dc47
Comment 15 Matthew Gregan [:kinetik] 2011-06-26 20:55:47 PDT
*** Bug 667040 has been marked as a duplicate of this bug. ***
Comment 16 Alice0775 White 2011-07-01 01:40:26 PDT
*** Bug 668742 has been marked as a duplicate of this bug. ***
Comment 17 dickvl 2011-07-01 05:23:11 PDT
Bug 668742 is about that this issue is still present in the current Firefox 5 release.

Can we expect any improvement in a Firefox 5 update or do we need to wait until Firefox 6 is released?

Then I know what to tell to people on he support forum that have this problem in Firefox 5.

You can see a list of support threads that show this problem in Firefox 5, so we can expect to see a lot more reports about this issue.

(cross posting this in bug Bug 668742  as this bug is resolved)
Comment 18 Boris Zbarsky [:bz] (still a bit busy) 2011-07-01 07:36:37 PDT
> Can we expect any improvement in a Firefox 5 update or do we need to wait until > Firefox 6 is released?

Most likely the latter.  That should happen in mid-August....
Comment 19 dickvl 2011-07-01 08:14:26 PDT
Thanks for confirming that.
I was already expecting that (porting code to another branch is not easy), but a confirmation helps to avoid confusion and disappointment.
Comment 20 Boris Zbarsky [:bz] (still a bit busy) 2011-07-01 08:33:45 PDT
It's not just porting; there are just no plans to do any Firefox 5 updates before Firefox 6 ships unless a critical issue comes up; if one does an update would contain a fix for just that issue.

Once Firefox 6 ships, it becomes the security update to Firefox 5, with automatic updates from 5 to 6.
Comment 21 Simona B [:simonab ] 2011-08-31 05:41:20 PDT
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0

Verified on Win XP, Win 7, Ubuntu 11.04 and Mac OS X 10.6 using the STR from the description. Image is now loaded and can be dragged into the canvas.

Setting resolution to VERIFIED FIXED.

Note You need to log in before you can comment on or make changes to this bug.