Last Comment Bug 663020 - Javascript/SVG Animation not working correctly in background tabs
: Javascript/SVG Animation not working correctly in background tabs
Status: VERIFIED FIXED
[fixed in 7 by 647001 but not in 6]
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: 5 Branch
: x86 Windows 7
: -- normal (vote)
: mozilla7
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.highcharts.com/demo/dynami...
Depends on: 647001
Blocks: 633421
  Show dependency treegraph
 
Reported: 2011-06-08 19:39 PDT by Michael
Modified: 2011-08-19 05:52 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
affected
+
wontfix
fixed


Attachments

Description Michael 2011-06-08 19:39:31 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

The dots on the chart will get stuck on the right hand side of the graph until the next data update.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.highcharts.com/demo/dynamic-update
2. Allow the graph to load and tick a few times
3. Switch to another tab for ~15 seconds
4. Come back to the tab and note the position of the dots and line before the next update tick.

Actual Results:  
Dots all clumped on the right side of the graph.

Expected Results:  
Dots continuing to move with the line as they do when the tab is in the Foreground

Hardware acceleration is on.
Comment 1 Michael 2011-06-08 19:53:37 PDT
Works as expected in Firefox 4.
Comment 3 Robert Longson 2011-06-09 00:30:37 PDT
or bug 586201 Does setting layout.throttled_frame_rate to 60 in about:config have any effect?
Comment 4 Boris Zbarsky [:bz] 2011-06-09 01:18:15 PDT
At first glance, looks like a likely duplicate of bug 647001... but I don't see why, given that the page seems to only use 1000ms timeouts.  Or is there a faster-running timeout on there somewhere?
Comment 5 Boris Zbarsky [:bz] 2011-06-09 01:20:08 PDT
jst, if we think this is something we need to fix for Fx5, I can try to write a quick patch for bug 647001 and see whether it helps...

Robert, that pref no longer does much of anything.
Comment 6 Daniel Holbert [:dholbert] 2011-06-09 09:09:59 PDT
Might also be related to bug 658189...
Comment 7 Boris Zbarsky [:bz] 2011-06-09 10:18:55 PDT
Unlikely; if I switch background tab setTimeout to a lower value (even 200ms is enough) the problem goes away.
Comment 8 Johnathan Nightingale [:johnath] 2011-06-13 14:29:35 PDT
Too late for 5, but since this will represent a regression in 5 so +'ng for tracking-6
Comment 9 Jesse Ruderman 2011-07-04 06:38:30 PDT
Fixed by bug 647001?
Comment 10 Michael 2011-07-04 09:33:10 PDT
The behavior is fixed in 7, I was still able to get it to occur once or twice in the 10 minutes that I tried. Nothing reproducible however.
Comment 11 Asa Dotzler [:asa] 2011-07-17 23:28:44 PDT
Are we going to try to do anything for 6 or are we calling this bug "done"?
Comment 12 Boris Zbarsky [:bz] 2011-07-18 07:04:57 PDT
I think we're calling this done....  The only fix here is to fix bug 647001, and that one wasn't approved for 6.
Comment 13 Trif Andrei-Alin[:AlinT] 2011-08-11 04:11:23 PDT
Mozilla/5.0 (Windows NT 6.1; rv:7.0a2) Gecko/20110810 Firefox/7.0a2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a2) Gecko/20110810 Firefox/7.0a2
Mozilla/5.0 (Windows NT 6.1; rv:8.0a1) Gecko/20110810 Firefox/8.0a1
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:8.0a1) Gecko/20110808 Firefox/8.0a1

I have tested it on these builds of Aurora and Nightly, and the bug does not reproduce anymore.
Can I change the status to VERIFIED FIXED?
Thanks!
Comment 14 Vlad [QA] 2011-08-19 05:52:19 PDT
Setting resolution to verified Fixed on Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0

The dots are moving correctly.

Note You need to log in before you can comment on or make changes to this bug.