Last Comment Bug 663038 - Set some preferences for e10s builds
: Set some preferences for e10s builds
Status: RESOLVED FIXED
[e10s]
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: Firefox 8
Assigned To: :Felipe Gomes (needinfo me!)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-08 23:19 PDT by :Felipe Gomes (needinfo me!)
Modified: 2011-07-08 13:17 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (2.19 KB, patch)
2011-06-08 23:19 PDT, :Felipe Gomes (needinfo me!)
dolske: review+
Details | Diff | Splinter Review
Use pref (1.29 KB, patch)
2011-06-08 23:31 PDT, :Felipe Gomes (needinfo me!)
dolske: review+
Details | Diff | Splinter Review

Description :Felipe Gomes (needinfo me!) 2011-06-08 23:19:09 PDT
Created attachment 538184 [details] [diff] [review]
Patch

Make builds built with --enable-e10s-compat to turn on e10s by default and disable hardware acceleration
Comment 1 :Felipe Gomes (needinfo me!) 2011-06-08 23:31:12 PDT
Created attachment 538189 [details] [diff] [review]
Use pref

(Was gonna post this in a separate bug but it seems unnecessary)

Uses the pref dom.ipc.tabs.enabled to create new tabs in the remote process.

This won't cover the first tab in the browser as the <browser> element is hard-coded in tabbrowser.. we'll need support to switch the remote="true" on/off for that

(and I think it's a good idea to leave the first tab as non-remote for the time being)
Comment 2 Justin Dolske [:Dolske] 2011-06-20 15:09:02 PDT
Comment on attachment 538184 [details] [diff] [review]
Patch

Review of attachment 538184 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with addressing the one comment either way.

::: browser/app/profile/firefox.js
@@ +905,5 @@
> +#ifdef MOZ_E10S_COMPAT
> +pref("dom.ipc.tabs.enabled", true);
> +#else
> +pref("dom.ipc.tabs.enabled", false);
> +#endif

Hmm. I'm inclined to say that this pref should remain hidden, since we're still a ways from supporting Firefox in E10S. When we're farther along and want people to start testing and experimenting, then we can include it (still defaulted to false).

Alternatively, I think I'd be ok with only exposing the pref on Nightly builds.
Comment 3 Justin Dolske [:Dolske] 2011-06-20 15:11:55 PDT
Comment on attachment 538189 [details] [diff] [review]
Use pref

Conversely to the above, this might as well be done without the #ifdef. If someone sets this pref, better to have stuff break right away than silently work unchanged until the day we un-ifdef this.
Comment 4 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-07-01 07:48:39 PDT
I backed out everything from central since Android and Maemo were unhappy about the push these changes were part of.
Comment 5 :Felipe Gomes (needinfo me!) 2011-07-08 13:17:03 PDT
http://hg.mozilla.org/mozilla-central/rev/b12c57161b96

Note You need to log in before you can comment on or make changes to this bug.