Last Comment Bug 663058 - "Cut" operation in Library or sidebar acts as "Copy"
: "Cut" operation in Library or sidebar acts as "Copy"
Status: RESOLVED FIXED
[5b5]
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: x86 All
: -- minor (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 416459
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-09 02:24 PDT by George Carstoiu
Modified: 2012-03-16 16:09 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description George Carstoiu 2011-06-09 02:24:32 PDT
Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0

An object that is cut (using either CTRL+C or the contextual menu) can be pasted several times - cut acts as though copy was performed.

Reproducible:always

Steps to reproduce:
 1. Go to Library
 2. Select a folder and use the Cut option
 3. Paste it in several locations

Actual results:
 - the object can be pasted several time

Expected results:
 - the object can be pasted just once
Comment 1 George Carstoiu 2011-06-09 02:25:59 PDT
Issue is present ever since Firefox 3.6.16
Comment 2 XtC4UaLL [:xtc4uall] 2011-06-09 08:53:13 PDT
(In reply to comment #0)
> Actual results:
>  - the object can be pasted several time

I'd rather expect this Behavior as other Applications do, no?
Comment 3 George Carstoiu 2011-06-10 02:30:49 PDT
(In reply to comment #2)
> (In reply to comment #0)
> > Actual results:
> >  - the object can be pasted several time
> 
> I'd rather expect this Behavior as other Applications do, no?

 Exactly - an item cannot be pasted to infinity if it was cut - logically it should be pasted only once
Comment 4 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-06-10 02:50:31 PDT
I think this happened forever, not only from 3.6.
Cut has a series of problems that should be solved, it was indeed implemented as "copy to clipboard and delete" for lack of time in the beginning.
Comment 5 XtC4UaLL [:xtc4uall] 2011-06-11 03:12:31 PDT
(In reply to comment #3)
> > I'd rather expect this Behavior as other Applications do, no?
> 
>  Exactly - an item cannot be pasted to infinity if it was cut - logically it
> should be pasted only once

Errm, my Point was that other Application bahave the same by allowing to paste a cut String multiple Times.
Comment 6 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-06-11 03:25:15 PDT
Well, Windows Explorer allows to paste just once after a cut, and it seems to make sense. I'm not sure about OS X or Linux.
Text handling is different as you said, but I guess that in this case the filemanager behavior is more consistent with the Library experience.
Comment 7 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-06-29 08:48:27 PDT
may be fixed by bug 416459

Note You need to log in before you can comment on or make changes to this bug.