Last Comment Bug 663277 - Increase memory allocated to JS Runtime in Dehydra
: Increase memory allocated to JS Runtime in Dehydra
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Rewriting and Analysis (show other bugs)
: Other Branch
: All All
: -- normal (vote)
: ---
Assigned To: Andrew McCreight [:mccr8]
:
: Michael Layzell [:mystor] [:mrl]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-09 17:07 PDT by Andrew McCreight [:mccr8]
Modified: 2011-06-09 17:38 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
increase mem allocated to JS runtime by almost 20 times (986 bytes, patch)
2011-06-09 17:15 PDT, Andrew McCreight [:mccr8]
taras.mozilla: review+
Details | Diff | Splinter Review

Description Andrew McCreight [:mccr8] 2011-06-09 17:07:57 PDT
With the default amount of memory, Dehydra frequently runs out of memory when compiling Firefox source code.  With this increase, I was able to compile the JS directory and a few others without problem.
Comment 1 Andrew McCreight [:mccr8] 2011-06-09 17:15:40 PDT
Created attachment 538389 [details] [diff] [review]
increase mem allocated to JS runtime by almost 20 times

Something a little less might work, too, but I think I was having problems even at quadruple the original memory.
Comment 2 Andrew McCreight [:mccr8] 2011-06-09 17:36:45 PDT
js/src/jsopcodes.cpp was the main offender, though at the default setting there was flakiness on other files.  I went back and tried slightly more fine-grained settings, and it was running out of memory for me at 0x256L, but 0x384L was okay.
Comment 3 Andrew McCreight [:mccr8] 2011-06-09 17:38:46 PDT
512 also works for me, FYI, which is what jcranmer pushed
http://hg.mozilla.org/rewriting-and-analysis/dehydra/rev/ef77d62c0dbd

Note You need to log in before you can comment on or make changes to this bug.