Last Comment Bug 663331 - U+2028 and U+2029 don't update line-state in the scanner
: U+2028 and U+2029 don't update line-state in the scanner
Status: RESOLVED FIXED
fixed-in-tracemonkey
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-10 01:05 PDT by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2011-06-20 17:04 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch and test (2.83 KB, patch)
2011-06-10 01:07 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
n.nethercote: review+
Details | Diff | Splinter Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2011-06-10 01:05:36 PDT
This might be a regression from bug 645598 -- it definitely looks like it looking at the code.  I could have sworn we had this bug before then, although ChatZilla's /eval command disagrees.  *shrug*
Comment 1 Jeff Walden [:Waldo] (remove +bmo to email) 2011-06-10 01:07:46 PDT
Created attachment 538453 [details] [diff] [review]
Patch and test

This picks up yet more points (or recovers them, whichever) on test262.
Comment 2 Nicholas Nethercote [:njn] 2011-06-10 02:33:52 PDT
Comment on attachment 538453 [details] [diff] [review]
Patch and test

Review of attachment 538453 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for fixing my regression!
Comment 3 Jeff Walden [:Waldo] (remove +bmo to email) 2011-06-13 18:16:45 PDT
http://hg.mozilla.org/tracemonkey/rev/5b2ffb7a2989
Comment 4 Chris Leary [:cdleary] (not checking bugmail) 2011-06-20 17:04:10 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/5b2ffb7a2989

Note You need to log in before you can comment on or make changes to this bug.