Closed Bug 663494 Opened 8 years ago Closed 8 years ago

crashing occurs when trying to restart after energysaving power down; crash [@ base::CloseSuperfluousFds]

Categories

(Firefox for Android Graveyard :: General, defect, critical)

Firefox 4.0
ARM
Android
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 622992

People

(Reporter: johnsc301, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.91 Safari/534.30
Build Identifier: Mozilla/5.0 (Android; Linux armv7l; rv:2.0.1) Gecko/20100101 Firefox/4.0.1 Fennec/2.0.1

I cannot get the user agent string since the browser cannot operate, so I looked it up and I believe this is the correct one. It is Firefox 4.0.1 on the Droid X.
Android 2.3.3
I had this problem on Android 2.2.1 as well.
After some crashes, the browser will be unusable after restarting and has a "messy" appearance. I ended the Firefox app process and turned off the phone repeatedly and still the browser is unusable. It becomes usable again usually, but there is no way to fix it except just waiting.
The extensions I run with it are adblock +, cleary, and quit for fennec.
The attached image is what the browser looks like in its unusable state.

Reproducible: Sometimes

Steps to Reproduce:
1. Open the browser
2. Quit or let it shut off by itself (is it supposed to do that?)
3. ...

Actual Results:  
The browser will crash and glitch upon starting up again.

Expected Results:  
It should start/restart just fine.

http://i51.tinypic.com/9vdthg.jpg
^ That's what the browser looks like in its unusable state.
In the URL section I put my homepage, google.
shadydogg2731, if you do get fennec to operate, could you post the link(s) that you see in about:crashes please?
OS: Linux → Android
Hardware: All → ARM
Version: Trunk → Firefox 4.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Firefox mobile on droid x renders itself completely unusable after some occasional crashes → Firefox mobile on droid x renders itself completely unusable after some occasional crashes; crash [libc.so@0x12c6e] on Droid X
Attached image screenshot
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:7.0a1)Gecko/20110623
Firefox/7.0a1 Fennec/7.0a1
Device: Motorola Droid 2
OS: Android 2.2

This issue occurs after I've installed several add-on (Quit Fennec, Nightly Tester Tools and Personas). Restart Notification was displayed on the top of the screen and after I've tapped on Restart button, the app reopened and the screen was blank. It seems that the  blank page has 4 options as you can see in the attached screenshot. All of them it seems that are working, excepting the "Add Search Engine" option. Also sidebars are displayed, if a pan left/right action is performed.
Summary: Firefox mobile on droid x renders itself completely unusable after some occasional crashes; crash [libc.so@0x12c6e] on Droid X → Firefox mobile on droid x renders itself completely unusable after some occasional crashes; crash [@ libc.so@0x12c6e ] on Droid X
Crash Signature: [@ libc.so@0x12c6e]
Crash Signature: [@ libc.so@0x12c6e] → [@ libc.so@0x12c6e][@ base::CloseSuperfluousFds]
Summary: Firefox mobile on droid x renders itself completely unusable after some occasional crashes; crash [@ libc.so@0x12c6e ] on Droid X → Firefox mobile on droid x renders itself completely unusable after some occasional crashes; crash [@ base::CloseSuperfluousFds] on Droid X
Appears to happen on the Nexus S as well.

Frame 	Module 	Signature [Expand] 	Source
0 	libc.so 	libc.so@0x12c0e 	
1 	libxul.so 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc:23
2 	libc.so 	libc.so@0x13eb0 	
3 	libxul.so 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc:23
4 	libc.so 	libc.so@0x144c0 	
5 	libc.so 	libc.so@0x171b8 	
6 	libxul.so 	base::CloseSuperfluousFds 	ipc/chromium/src/base/process_util_posix.cc:138
7 	libxul.so 	base::LaunchApp 	stl_tree.h:243
8 	libxul.so 	mozilla::ipc::GeckoChildProcessHost::PerformAsyncLaunchInternal 	ipc/glue/GeckoChildProcessHost.cpp:680
9 	libxul.so 	mozilla::ipc::GeckoChildProcessHost::PerformAsyncLaunch 	ipc/glue/GeckoChildProcessHost.cpp:370
10 	libxul.so 	RunnableMethod<mozilla::ipc::GeckoChildProcessHost, bool , Tuple2<std::vector<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >, base::ProcessArchitecture> >::Run 	ipc/chromium/src/base/tuple.h:400
11 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:343
12 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:353
13 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:450
14 	libxul.so 	base::MessagePumpLibevent::Run 	ipc/chromium/src/base/message_pump_libevent.cc:310
15 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:219
16 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:511
17 	libxul.so 	base::Thread::ThreadMain 	ipc/chromium/src/base/thread.cc:159
18 	libxul.so 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc:28
19 	libc.so 	libc.so@0x118e7 	
20 	libc.so 	libc.so@0x114b3
Crash Signature: [@ libc.so@0x12c6e][@ base::CloseSuperfluousFds] → [@ libc.so@0x12c6e][@ base::CloseSuperfluousFds] [@ libc.so@0x12c0e ]
Summary: Firefox mobile on droid x renders itself completely unusable after some occasional crashes; crash [@ base::CloseSuperfluousFds] on Droid X → crashing occurs when trying to restart after energysaving power down; crash [@ base::CloseSuperfluousFds] on Droid X/Nexus S
Naoki, does this mean that we have STR? This is one of the more mysterious ones I've seen, so STR would be lovely.
I can't seem to reproduce this bug in the latest version of the nightly using Tony's Nexus S.  Mozilla/5.0 (Android; Linux armv71; rv8.0a1) Gecko/20110727 Firefox/8.0a1 Fennec/8.0a1

I'll monitor the crash list to see if it occurs again.
Looks like it's not just on the Motorola.  Also occurred:
samsung SGH-I897
google/soju/crespo:2.3.4/GRJ22/121341:user/release-keys on the nightly:
https://crash-stats.mozilla.com/report/index/68c80328-1b7b-4b3e-a746-4e0c62110801
Summary: crashing occurs when trying to restart after energysaving power down; crash [@ base::CloseSuperfluousFds] on Droid X/Nexus S → crashing occurs when trying to restart after energysaving power down; crash [@ base::CloseSuperfluousFds]
Crash Signature: [@ libc.so@0x12c6e][@ base::CloseSuperfluousFds] [@ libc.so@0x12c0e ] → [@ libc.so@0x12c6e][@ base::CloseSuperfluousFds] [@ libc.so@0x12c0e ][@ libc.so@0x1306e ] [@ libc.so@0x1306e]
Dupe of bug 622992?
Crash Signature: [@ libc.so@0x12c6e][@ base::CloseSuperfluousFds] [@ libc.so@0x12c0e ][@ libc.so@0x1306e ] [@ libc.so@0x1306e] → [@ libc.so@0x12c6e][@ base::CloseSuperfluousFds] [@ libc.so@0x12c0e ][@ libc.so@0x1306e ] [@ libc.so@0x1306e] [@ libc.so@0x12c3e ]
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 622992
You need to log in before you can comment on or make changes to this bug.