Closed Bug 663580 Opened 10 years ago Closed 5 years ago

Determine if private browsing causes HTTP cache invalidation/flushing

Categories

(Core :: Networking: Cache, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: jduell.mcbugs, Unassigned)

References

(Blocks 1 open bug)

Details

We're getting reports (see bug 651011 comment 0 and 7) of lots of cache I/O when leaving Private Browsing mode.   We should look into whether/why this is happening.  Not clear if it's cache invalidation or some other thing that might cause lots of eviction.
Entering Private Browsing clears the cache.

http://mxr.mozilla.org/mozilla-central/source/browser/components/privatebrowsing/src/nsPrivateBrowsingService.js?force=1#571

588       // NOTE: there is no way to clear just that domain, so we clear out
589       //       everything)
590       try {
591         cs.evictEntries(Ci.nsICache.STORE_ANYWHERE);
592       } catch (ex) {
593         Cu.reportError("Exception thrown while clearing the cache: " +
594           ex.toString());
595       }
No, I'm sorry, that's incorrect. The only places that actually call removeDataFromDomain are about:permissions and http://mxr.mozilla.org/mozilla-central/source/browser/components/places/content/controller.js#257, so that's potentially a red herring.
Aha, I knew I wasn't making things up: http://mxr.mozilla.org/mozilla-central/source/netwerk/cache/nsCacheService.cpp#2515

That's called every time private browsing is entered or exited.
Will get fixed in bug 666059
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 666059
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
When leaving PB mode we don't delete the disk cache as mentioned in description of bug #666059. At least not internally in cache service. We disable disk (and offline) cache when entering PB mode and enable it again when leaving the PB mode.

Comment #1 points to a JS code that evicts all entries and AFAICS this has nothing to do with leaving PB. But I'm having hard time to find out when exactly is this code called. I've found these references:

http://mxr.mozilla.org/mozilla-central/source/browser/components/places/content/placesOverlay.xul#109
http://mxr.mozilla.org/mozilla-central/source/browser/components/preferences/aboutPermissions.js#268
As pointed out in comment 2, comment 1 is bogus. Comment 3 is where the facts are.
The line numbers have changed. Anyway if you mean nsCacheService::OnEnterExitPrivateBrowsing() then this bug is invalid since as I wrote in comment #5 we don't delete the disk cache.

If there is sometimes really lot of cache I/O we need a STR since I can't reproduce it.
invalid based on comment 7.. if it should be reopened please do so
Status: REOPENED → RESOLVED
Closed: 10 years ago5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.