Last Comment Bug 663771 - HistoryMenu.toggleTabsFromOtherComputers doesn't account for other uses of the HistoryMenu class
: HistoryMenu.toggleTabsFromOtherComputers doesn't account for other uses of th...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 7
Assigned To: Geoff Lankow (:darktrojan)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-13 02:29 PDT by Geoff Lankow (:darktrojan)
Modified: 2011-06-19 04:08 PDT (History)
3 users (show)
mounir: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.20 KB, patch)
2011-06-13 02:29 PDT, Geoff Lankow (:darktrojan)
mak77: review+
Details | Diff | Review
patch for checkin (2.52 KB, patch)
2011-06-18 02:01 PDT, Geoff Lankow (:darktrojan)
no flags Details | Diff | Review

Description Geoff Lankow (:darktrojan) 2011-06-13 02:29:45 PDT
Created attachment 538838 [details] [diff] [review]
patch

The function toggles the 'tabs from other computers' item on the main history menu, regardless of which menu is displayed. The app button history menu uses the same class (although it doesn't have the menu item in question), and I know of at least one addon that uses it (because I wrote it).
Comment 1 Dão Gottwald [:dao] 2011-06-16 03:27:17 PDT
(In reply to comment #0)
> The app button history
> menu uses the same class (although it doesn't have the menu item in
> question),

What class does it use?
Comment 2 Geoff Lankow (:darktrojan) 2011-06-16 15:11:00 PDT
HistoryMenu (by class I mean in Javascript not CSS, why do these things have to have the same name?)
Comment 3 Dão Gottwald [:dao] 2011-06-16 15:39:24 PDT
Well, to be precise, JS doesn't have classes. ;-)
Comment 4 Marco Bonardo [::mak] 2011-06-17 08:19:40 PDT
Comment on attachment 538838 [details] [diff] [review]
patch

Review of attachment 538838 [details] [diff] [review]:
-----------------------------------------------------------------

nit: What about a small comment like (feel free to make it real english): "// In some of the menus handled by HistoryMenu this menuitem may not exist."
Comment 5 Geoff Lankow (:darktrojan) 2011-06-18 02:01:01 PDT
Created attachment 540222 [details] [diff] [review]
patch for checkin
Comment 6 Phil Ringnalda (:philor) 2011-06-18 20:39:53 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/4c809dfcb658
Comment 7 Mounir Lamouri (:mounir) 2011-06-19 04:08:32 PDT
Merged:
http://hg.mozilla.org/mozilla-central/rev/4c809dfcb658

Note You need to log in before you can comment on or make changes to this bug.