Last Comment Bug 663829 - [Regression] Checkboxes are difficult to check on Gmail
: [Regression] Checkboxes are difficult to check on Gmail
Status: VERIFIED FIXED
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Firefox 6
: ARM Android
: P2 normal (vote)
: Firefox 7
Assigned To: Benjamin Stover (:stechz)
:
:
Mentors:
Depends on:
Blocks: 658727 664332
  Show dependency treegraph
 
Reported: 2011-06-13 08:27 PDT by Aakash Desai [:aakashd]
Modified: 2011-07-28 15:32 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Checkboxes are difficult to check on Gmail (1.93 KB, patch)
2011-06-22 16:03 PDT, Benjamin Stover (:stechz)
wjohnston2000: review+
Details | Diff | Splinter Review

Description Aakash Desai [:aakashd] 2011-06-13 08:27:47 PDT
Build Id:
Mozilla/5.0 (Android; Linux armv7l; rv:7.0a1) Gecko/20110612 Firefox/7.0a1 Fennec/7.0a1 ID:20110612040154

Mozilla/5.0 (Android; Linux armv7l; rv:6.0a2) Gecko/20110612 Firefox/6.0a2 Fennec/6.0a2 ID:20110613054928

Note: This was not seen on the 6/6 build of Aurora. So, the regression window is between 6/6 - 6/12 Aurora. I tried this on mail.mozilla.com/zimbra and all the checkboxes there checked fine.

Step to Reproduce:
1. Go to www.gmail.com and login
2. Try to click on a bunch of checkboxes

Actual Results:
Not all the checkboxes will be checked (I was only able to check half of them even though each one, when tapped on, highlighted blue for 1/2 a second.

Expected Results:
All the checkboxes should be checked.
Comment 1 Aaron Train [:aaronmt] 2011-06-13 08:41:29 PDT
Seeing this too (06/13, HTC Nexus One), but not just Gmail, really anywhere with checkboxes: 

http://www.echoecho.com/htmlforms09.htm
Comment 2 Aaron Train [:aaronmt] 2011-06-20 07:25:09 PDT
Still seeing this on 06/20, unable to toggle value changes in checkboxes by tapping them
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-06-21 13:58:53 PDT
Ben - Take a look at this. I can repro using a nightly
Comment 4 Benjamin Stover (:stechz) 2011-06-22 15:15:21 PDT
At first I thought this could be some displayport problem, but these checkboxes *can* be checked after a couple of pokes. This makes me think that maybe we are cancelling taps sometimes when we shouldn't be (I've had this happen to me clicking links too).

Looking into it.
Comment 5 Benjamin Stover (:stechz) 2011-06-22 15:31:39 PDT
Surprisingly, things look to be OK from Fennec's perspective. Very interesting. Lots of WARNINGs exactly when the click does not fire.
Comment 6 Benjamin Stover (:stechz) 2011-06-22 16:03:52 PDT
Created attachment 541213 [details] [diff] [review]
Checkboxes are difficult to check on Gmail

I'm confused how this was working at all before, because I think Rects can't
take a JSON top/left/width/height structure. Additionally, it's sometimes
possible to tap on the border of the checkbox where we consider it fractionally
"in bounds." This subtlety is lost on mouse events that I presume only deal
with integer offsets.

This code works pretty well for me now. Fast taps on different checkboxes is a
pain, but that is a balancing game with double tap that we can leave to a
separate bug.
Comment 7 Wesley Johnston (:wesj) 2011-06-23 13:21:02 PDT
Comment on attachment 541213 [details] [diff] [review]
Checkboxes are difficult to check on Gmail

Review of attachment 541213 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 8 Benjamin Stover (:stechz) 2011-06-23 18:54:58 PDT
Pushed to inbound http://hg.mozilla.org/integration/mozilla-inbound/rev/daf896f89f39
Comment 9 Marco Bonardo [::mak] 2011-06-24 02:57:10 PDT
http://hg.mozilla.org/mozilla-central/rev/daf896f89f39
Comment 10 Anna (Waverley) 2011-06-27 08:19:17 PDT
VERIFIED FIXED on:

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110627 Firefox/7.0a1 Fennec/7.0a1 

Mozilla /5.0 (Android;Linux armv7l;rv:6.0a2) Gecko/20110627 Firefox/6.0a2 Fennec/6.0a2 

Device: HTC Desire Z (Android 2.2)
Comment 11 Matt Brubeck (:mbrubeck) 2011-06-27 09:42:52 PDT
Comment on attachment 541213 [details] [diff] [review]
Checkboxes are difficult to check on Gmail

Nominating for approval-mozilla-aurora.  Straightforward low-risk fix for a regression that was reported as affecting both Aurora and trunk.  The fix touches mobile front-end code only (zero desktop risk).
Comment 12 Matt Brubeck (:mbrubeck) 2011-06-27 17:53:45 PDT
The main part of this bug is a regression from bug 658727 which has not landed in Aurora, so this problem should not be as bad in Aurora as it is in Nightly.  The other part fixed by this patch does not appear to be a regression from previous versions, so I'm not sure it's necessary to take it in Aurora.

Note You need to log in before you can comment on or make changes to this bug.