Intermittent Mac dom/tests/mochitest/general/test_497898.html | Test timed out followed by failures in or test_clipboard_events.html, test_focusrings.xul, test_offsets.xul

RESOLVED DUPLICATE of bug 663993

Status

defect
RESOLVED DUPLICATE of bug 663993
8 years ago
6 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [test which aborts the suite])

+++ This bug was initially created as a clone of Bug #529217 +++

See bug 529217 comment 54 for some history.

Rev3 MacOSX Leopard 10.5.8 mozilla-beta opt test mochitests-3/5 on 2011/06/13 15:18:13

http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Beta/1308003493.1308007834.22826.gz

5434 INFO TEST-START | /tests/dom/tests/mochitest/general/test_497898.html
5435 INFO Error: Unable to restore focus, expect failures and timeouts.
NEXT ERROR 5436 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/general/test_497898.html | Test timed out.
5437 INFO TEST-END | /tests/dom/tests/mochitest/general/test_497898.html | finished in 312187ms
5438 INFO TEST-START | /tests/dom/tests/mochitest/general/test_bug504220.html
5439 INFO Error: Unable to restore focus, expect failures and timeouts.
5440 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_bug504220.html | document.body should contain 'onhashchange'.
5441 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_bug504220.html | window should contain 'onhashchange'.
5442 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_bug504220.html | undefined - function () {
    return 42;
} should equal function () {
    return 42;
}
5443 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_bug504220.html | undefined - function () {
    numEvents++;
    gGen.next();
} should equal function () {
    numEvents++;
    gGen.next();
}
5444 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_bug504220.html | Exactly one hashchange should have been fired. - 1 should equal 1
5445 INFO TEST-END | /tests/dom/tests/mochitest/general/test_bug504220.html | finished in 3164ms
5446 INFO TEST-START | /tests/dom/tests/mochitest/general/test_bug631440.html
5447 INFO Error: Unable to restore focus, expect failures and timeouts.
5448 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_bug631440.html | Should have thrown a security exception
5449 INFO TEST-END | /tests/dom/tests/mochitest/general/test_bug631440.html | finished in 3152ms
5450 INFO TEST-START | /tests/dom/tests/mochitest/general/test_clipboard_events.html
5451 INFO Error: Unable to restore focus, expect failures and timeouts.
5452 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_clipboard_events.html | set/get clipboard text failed - "empty_0.702498673468384" should equal "empty_0.702498673468384"
NEXT ERROR 5453 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/general/test_clipboard_events.html | Test timed out.
5454 INFO TEST-END | /tests/dom/tests/mochitest/general/test_clipboard_events.html | finished in 323731ms
5455 INFO TEST-START | /tests/dom/tests/mochitest/general/test_consoleAPI.html
5456 INFO Error: Unable to restore focus, expect failures and timeouts.
5457 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_consoleAPI.html | console exists
5458 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_consoleAPI.html | random property doesn't throw

 Skipping 26 Lines...

5485 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils.html | at index 13 for data [0, 100000, true, true] - [object HTMLDivElement] should equal [object HTMLDivElement]
5486 INFO TEST-END | /tests/dom/tests/mochitest/general/test_domWindowUtils.html | finished in 3112ms
5487 INFO TEST-START | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html
5488 INFO Error: Unable to restore focus, expect failures and timeouts.
5489 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | getScrollXY x for test: initial getScrollXY state - 0 should equal 0
5490 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | getScrollXY y for test: initial getScrollXY state - 0 should equal 0
5491 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | getScrollXY x for test: initial getScrollXY state+flush - 0 should equal 0
5492 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | getScrollXY y for test: initial getScrollXY state+flush - 0 should equal 0
5493 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | scrollX for test: initial window.scroll* state - 0 should equal 0
5494 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | scrollY for test: initial window.scroll* state - 0 should equal 0
5495 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | getScrollXY x for test: after scroll getScrollXY state - 900 should equal 900
5496 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | getScrollXY y for test: after scroll getScrollXY state - 1000 should equal 1000
5497 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | getScrollXY x for test: after scroll getScrollXY state+flush - 900 should equal 900
5498 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | getScrollXY y for test: after scroll getScrollXY state+flush - 1000 should equal 1000
5499 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | scrollX for test: after scroll window.scroll* state - 900 should equal 900
5500 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | scrollY for test: after scroll window.scroll* state - 1000 should equal 1000
5501 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | getScrollXY x for test: didn't flush layout for getScrollXY - 900 should equal 900
5502 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | getScrollXY y for test: didn't flush layout for getScrollXY - 1000 should equal 1000
5503 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | getScrollXY x for test: flushed layout for getScrollXY - 0 should equal 0
5504 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | getScrollXY y for test: flushed layout for getScrollXY - 0 should equal 0
5505 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | scrollX is zero for display:none iframe - 0 should equal 0
5506 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | scrollY is zero for display:none iframe - 0 should equal 0
5507 INFO TEST-END | /tests/dom/tests/mochitest/general/test_domWindowUtils_scrollXY.html | finished in 3115ms
5508 INFO TEST-START | /tests/dom/tests/mochitest/general/test_focusrings.xul
5509 INFO Error: Unable to restore focus, expect failures and timeouts.
5510 INFO TEST-INFO | /tests/dom/tests/mochitest/general/test_focusrings.xul | before wait for focus -- loaded: uninitialized active window: <no window active> focused window: <no window focused> desired window: ([object Window]) http://mochi.test:8888/tests/dom/tests/mochitest/general/test_focusrings.xul child window: ([object Window]) http://mochi.test:8888/tests/dom/tests/mochitest/general/test_focusrings.xul docshell visible: true
5511 INFO TEST-INFO | /tests/dom/tests/mochitest/general/test_focusrings.xul | must wait for load
5512 INFO TEST-INFO | /tests/dom/tests/mochitest/general/test_focusrings.xul | must wait for focus
5513 INFO TEST-INFO | /tests/dom/tests/mochitest/general/test_focusrings.xul | waitForEvent called <type:load, target[object XULDocument]> -- loaded: complete active window: <no window active> focused window: <no window focused> desired window: ([object Window]) http://mochi.test:8888/tests/dom/tests/mochitest/general/test_focusrings.xul child window: ([object Window]) http://mochi.test:8888/tests/dom/tests/mochitest/general/test_focusrings.xul docshell visible: true
5514 INFO TEST-INFO | /tests/dom/tests/mochitest/general/test_focusrings.xul | maybe run tests <load:true, focus:false> -- loaded: complete active window: <no window active> focused window: <no window focused> desired window: ([object Window]) http://mochi.test:8888/tests/dom/tests/mochitest/general/test_focusrings.xul child window: ([object Window]) http://mochi.test:8888/tests/dom/tests/mochitest/general/test_focusrings.xul docshell visible: true
5515 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/general/test_focusrings.xul | Test timed out.
5516 INFO TEST-END | /tests/dom/tests/mochitest/general/test_focusrings.xul | finished in 320721ms
5517 INFO TEST-START | /tests/dom/tests/mochitest/general/test_frameElementWrapping.html
5518 INFO Error: Unable to restore focus, expect failures and timeouts.
5519 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_frameElementWrapping.html | no wrapper needed if same origin
5520 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_frameElementWrapping.html | wrapper needed if not same origin

 Skipping 615 Lines...

6136 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | nonappended bounding rect width - 0 should equal 0
6137 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | nonappended bounding rect height - 0 should equal 0
6138 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | nonappended bounding rect right - 0 should equal 0
6139 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | nonappended bounding rect bottom - 0 should equal 0
6140 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | nonappended getClientRects empty - 0 should equal 0
6141 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | scrollbox scrollLeft after vertical scroll - 0 should equal 0
6142 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | scrollbox scrollTop after vertical scroll - 20 should equal 20
6143 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | child position after vertical scroll - 194.8000030517578 should equal 194.8000030517578
6144 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | scrollbox scrollLeft after vertical scroll reset - 0 should equal 0
6145 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | scrollbox scrollTop after vertical scroll reset - 0 should equal 0
6146 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | child position after vertical scroll reset - 214.8000030517578 should equal 214.8000030517578
6147 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | scrollbox scrollLeft after vertical scroll negative - 0 should equal 0
6148 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | scrollbox scrollTop after vertical scroll negative - 0 should equal 0
6149 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | child position after vertical scroll negative - 214.8000030517578 should equal 214.8000030517578
6150 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | scrollbox scrollLeft after horizontal scroll - 18 should equal 18
6151 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | scrollbox scrollTop after horizontal scroll - 0 should equal 0
6152 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | child position after horizontal scroll - 2 should equal 2
6153 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | scrollbox scrollLeft after horizontal scroll reset - 0 should equal 0
6154 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | scrollbox scrollTop after horizontal scroll reset - 0 should equal 0
6155 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | child position after horizontal scroll reset - 20 should equal 20
6156 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | input-nosize scrollLeft after nonscroll - 0 should equal 0
6157 INFO TEST-PASS | /tests/dom/tests/mochitest/general/test_offsets.html | input-nosize scrollTop after nonscroll - 0 should equal 0
6158 INFO TEST-END | /tests/dom/tests/mochitest/general/test_offsets.html | finished in 3296ms
6159 INFO TEST-START | /tests/dom/tests/mochitest/general/test_offsets.xul
6160 INFO Error: Unable to restore focus, expect failures and timeouts.
6161 INFO TEST-INFO | /tests/dom/tests/mochitest/general/test_offsets.xul | before wait for focus -- loaded: uninitialized active window: <no window active> focused window: <no window focused> desired window: ([object Window]) http://mochi.test:8888/tests/dom/tests/mochitest/general/test_offsets.xul child window: ([object Window]) http://mochi.test:8888/tests/dom/tests/mochitest/general/test_offsets.xul docshell visible: true
6162 INFO TEST-INFO | /tests/dom/tests/mochitest/general/test_offsets.xul | must wait for load
6163 INFO TEST-INFO | /tests/dom/tests/mochitest/general/test_offsets.xul | must wait for focus
6164 INFO TEST-INFO | /tests/dom/tests/mochitest/general/test_offsets.xul | waitForEvent called <type:load, target[object XULDocument]> -- loaded: complete active window: <no window active> focused window: <no window focused> desired window: ([object Window]) http://mochi.test:8888/tests/dom/tests/mochitest/general/test_offsets.xul child window: ([object Window]) http://mochi.test:8888/tests/dom/tests/mochitest/general/test_offsets.xul docshell visible: true
6165 INFO TEST-INFO | /tests/dom/tests/mochitest/general/test_offsets.xul | maybe run tests <load:true, focus:false> -- loaded: complete active window: <no window active> focused window: <no window focused> desired window: ([object Window]) http://mochi.test:8888/tests/dom/tests/mochitest/general/test_offsets.xul child window: ([object Window]) http://mochi.test:8888/tests/dom/tests/mochitest/general/test_offsets.xul docshell visible: true
6166 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/general/test_offsets.xul | Test timed out.
6167 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | 4 test timeouts, giving up.
6168 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | Skipping 151 remaining tests.
The above log is from talos-r3-leopard-057.
This has also failed recently on talos-r3-leopard-055.

According to bug 529217 comment 54 this is "apparently the result of broken slaves with an OS dialog getting in the way."  Moving to releng.  See also similar (fixed) bug 570843.
Component: DOM → Release Engineering
Product: Core → mozilla.org
QA Contact: general → release
Version: Trunk → other
Have you seen this in jobs which started *after* since bug 663993 was resolved ?
(In reply to comment #2)
> Have you seen this in jobs which started *after* since bug 663993 was
> resolved ?

No.  Marking as duplicate.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 663993
Whiteboard: [orange][test which aborts the suite] → [test which aborts the suite]
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.