Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: sumanbommalata, Unassigned)

Tracking

4.0.1
x86
Windows Vista

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17
Build Identifier: 

I am using Bugzilla 4.0.1. Its working fine. But for remote bug posting i am using Zend XML RPC. Below is the my code.

require_once 'Zend/XmlRpc/Client.php';
$oClient = new Zend_XmlRpc_Client('http://localhost/bugzilla/xmlrpc.cgi');
$oHttpClient = new Zend_Http_Client();
$oHttpClient->setCookieJar();
$oClient->setHttpClient($oHttpClient);
$aResponse = $oClient->call('User.login',array(array('login'=>'peterh@mydomain.com','password'=>'mypassword','remember'=>1)));
$aResponse = $oClient->call('Bug.create', array(array(
'product' => "My Product",
'component' => "My Component",
'summary' => "This is the summary of the bug I'm creating",
'version' => "unspecified",
'description' => "This is a description of the bug",
'op_sys' => "All",
'platform' => "---",
'priority' => "P5",
'severity' => "Trivial"
)));
$iBugId = $aResponse['id'];
$aResponse = $oClient->call('User.logout');


But its showing error while i execute this.


Below is the error.

Fatal error: Uncaught exception 'Zend_XmlRpc_Client_FaultException' with message 'The requested method 'User.login' was not found.' in D:\wamp\www\bugcreate\Zend\XmlRpc\Client.php:370 Stack trace: #0 D:\wamp\www\bugcreate\zend.php(9): Zend_XmlRpc_Client->call('User.login', Array) #1 {main} thrown in D:\wamp\www\bugcreate\Zend\XmlRpc\Client.php on line 370


If anyone has ideas please help me.

Reproducible: Always
Group: bugzilla-security

Comment 1

7 years ago
Looks like a support question to me. I will let mkanat decide.
Severity: major → normal
Version: unspecified → 4.0.1

Comment 2

7 years ago
Yeah, I'm pretty sure this is more of a support question (in the sense of "How do I do X with Bugzilla?") and probably not a bug in our system.

Suman: Probably the best way to get your question answered would be to write to the support-bugzilla mailing list, described here:

  http://www.bugzilla.org/support/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.