Last Comment Bug 664125 - Offline error page only appears for caching channels
: Offline error page only appears for caching channels
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: neil@parkwaycc.co.uk
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-14 06:40 PDT by neil@parkwaycc.co.uk
Modified: 2011-06-16 15:42 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Proposed patch (1.96 KB, patch)
2011-06-14 07:07 PDT, neil@parkwaycc.co.uk
bzbarsky: review+
Details | Diff | Review

Description neil@parkwaycc.co.uk 2011-06-14 06:40:37 PDT
Steps to reproduce problem:
1. Go offline
2. Try to visit an FTP site
3. Try to open a web page

Expected result: Error page at step 2

Actual result: Error page at step 3

This is because NS_ERROR_DOCUMENT_NOT_CACHED triggers the offline page, while NS_ERROR_OFFLINE triggers no error at all!
Comment 1 neil@parkwaycc.co.uk 2011-06-14 07:07:35 PDT
Created attachment 539191 [details] [diff] [review]
Proposed patch
Comment 2 Boris Zbarsky [:bz] 2011-06-15 13:20:27 PDT
Comment on attachment 539191 [details] [diff] [review]
Proposed patch

r=me
Comment 3 neil@parkwaycc.co.uk 2011-06-16 15:42:51 PDT
Pushed changeset 8cbd3bbce29e to mozilla-central.

Note You need to log in before you can comment on or make changes to this bug.