Cannot edit Demo Studio demos

RESOLVED FIXED

Status

Mozilla Developer Network
Wiki pages
--
critical
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: openjck, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Jay has reported that he cannot edit Demo Studio demos. He can click the "Edit" button that he sees and edit the demo as normal, but when he clicks "Save" he sees an Internal Server Error.

We are not sure if / how this affects users.

* Can users edit their own demos?
* Can users submit demos?
(Reporter)

Comment 1

6 years ago
Because of this, administrators cannot manually add existing demos to the Dev Derby.
(In reply to comment #1)
> Because of this, administrators cannot manually add existing demos to the
> Dev Derby.

Which demo(s) in particular? I was able to edit a few successfully.
(Reporter)

Comment 3

6 years ago
Jay was having trouble with the "Fly-in Form" demo, but I see that it is now listed on the Dev Derby page.

https://developer.mozilla.org/en-US/demos/detail/fly-in-form
(In reply to comment #3)
> Jay was having trouble with the "Fly-in Form" demo, but I see that it is now
> listed on the Dev Derby page.
> 
> https://developer.mozilla.org/en-US/demos/detail/fly-in-form

Hmm... I could edit that one too, added and removed a tag. Not sure what might have happened there.
(Reporter)

Comment 5

6 years ago
Jay noticed that his settings were saved when he hit the "Save" button, despite the 500 error. This might explain why the demo is showing up on the Dev Derby site after all.

Comment 6

6 years ago
les:  the bug summary might be misleading... here is what i did:

1. on demo details page, i clicked the edit demo button, checked the dev derby box and clicked save.
2. got an ISE 500 (didn't verify if the changes stuck)
3. went to django admin, added the tag manually and saved
4. noticed the demo was now in dev derby

------------

then i tried to test changing something else... 

1. open demo details page, edit, changed title of demo, save
2. got an ISE 500
3. the name change stuck... even with the error

so it looks like i get an ISE when i try to save an existing demo through the MDN ui... but the changes are preserved. 

not sure why i get the 500 error... which is what this bug is really about.

anyone else see a 500 error when editing an existing demo and trying to save?
Steps to reproduce helped, thanks. The admin pages work fine, it's the general site UI that throws an error on edit. Definitely a bug, and I just pushed a fix:

https://github.com/mozilla/kuma/commit/9f01d6af25b624a8a0fc3f26d59f45f1502a367e

Need to get more tests wrapped around this stuff, ugh.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Summary: Administrators cannot edit Demo Studio demos → Cannot edit Demo Studio demos
For good measure, added tests to make sure demo editing works:

https://github.com/mozilla/kuma/commit/56e55702a269d4b8c0d817a1a896c30bb27833bc
(Assignee)

Updated

5 years ago
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.