Entering newline after Japanese in a textarea doesn't change cursor position

RESOLVED FIXED in Firefox 7

Status

()

Core
Widget: Android
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mark hosang, Assigned: m_kato)

Tracking

({inputmethod})

Trunk
mozilla8
ARM
Android
inputmethod
Points:
---

Firefox Tracking Flags

(firefox7 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: Mozilla/5.0 (Android; Linux armv7l;rv2.1.1) Gecko/20110415 Firefox/4.0.2pre Fennec/4.0.1

When typing in a textarea with the Japanese keyboard set to 「あ」, if you enter in a Japanese word followed by a newline, the newline gets inputted into the textarea, but the cursor doesn't move to the newline.  That is to say, the cursor is still located at the end of just entered Japanese word.

Reproducible: Always

Steps to Reproduce:
1.Click on textarea to bring up keyboard
2.Make sure input mode is set to あ
3.input "k" "e" "n"
4.Select any option available, in my case けんめい
5.Hit the return key (will cause select options to disappear)
6.Hit the return key again


Actual Results:  
Cursor fails to update position to after the newline.

Expected Results:  
Cursor moves to next line after the newline

This is reproducible on both the Galaxy S 2.3.3, Galapagos 2.2.1, Galaxy Tab 2.2 in the firefox add-on.

This is NOT producible in the native browser (devkit?). 

This is also producible when inputting english via the Japanese 「あ」keyboard.
(Reporter)

Updated

6 years ago
Keywords: inputmethod, intl, jp-critical
OS: Other → Android
Hardware: Other → ARM
Version: unspecified → 4.0 Branch
mark, although I cannot reproduce this on Nightly, could you reproduce this using Nightly build?  You can get it from http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-r7/
(Reporter)

Comment 2

6 years ago
Hi Kato-san,
   I just installed the nightly and the bug still exists.

here is a site you can try. 
http://www.w3schools.com/tags/showit.asp?filename=tryhtml_textarea

the key is that you have to enter in a word in Japanese first for the newline to stop working.  To reiterate, if you just click on the textarea while in the kana keyboard mode, you'll be able to enter in newlines.  However, just entering just one word like "kanari" you won't be able to get the cursor to move for any subsequent newline.
Thanks, Mark.  Confirmed on latest nightly
Status: UNCONFIRMED → NEW
Component: General → General
Ever confirmed: true
Product: Firefox → Fennec
QA Contact: general → general
Version: 4.0 Branch → Trunk
Also, This can reproduce on iWnn, but if using ATOK, it is no problem.
(Assignee)

Updated

6 years ago
Keywords: intl, jp-critical
When reproducing this, setComposionText() is called.  Since Gecko detects that composing is started, so caret isn't updated.

I believe that this is an iWnn bug, but we should fix this.
Assignee: nobody → m_kato
(Assignee)

Updated

6 years ago
Assignee: m_kato → nobody
Component: General → Widget: Android
Product: Fennec → Core
QA Contact: general → android
Created attachment 547006 [details] [diff] [review]
fix
Assignee: nobody → m_kato
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Attachment #547006 - Flags: review?(nchen)
Comment on attachment 547006 [details] [diff] [review]
fix

># HG changeset patch
># Parent f649b717749526de2b831cb471906532689ed0e3
>
> 
>         if (!mComposing) {
>+            if (mComposingText.length() == 0) {
>+              // Some IMEs such as iWnn sometimes call with empty composing 
>+              // text.  (See bug 664364)
>+              // If composing text is empty, ignore this and don't start
>+              // compositing.
>+              return true;
>+            }
>+
>             // Get current selection
>             GeckoAppShell.sendEventToGecko(
>                 new GeckoEvent(GeckoEvent.IME_GET_SELECTION, 0, 0));

Can you change indent to 4 spaces? Thanks.
Attachment #547006 - Flags: review?(nchen) → review+
http://hg.mozilla.org/integration/mozilla-inbound/rev/57d55c25dbe4
Whiteboard: [inbound]
http://hg.mozilla.org/mozilla-central/rev/57d55c25dbe4
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → mozilla8
(Reporter)

Comment 10

6 years ago
Thanx Makoto this fixed our problem.
Comment on attachment 547006 [details] [diff] [review]
fix

requesting for Firefox 7.  This bugs occurs with iWnn that installed into most devices in Japanese devices.
Attachment #547006 - Flags: approval-mozilla-aurora?
Attachment #547006 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
http://hg.mozilla.org/releases/mozilla-aurora/rev/ebf113b69bd8
status-firefox7: --- → fixed
Hrm.  It appears that you can install the iWnnIME on Android if your phone is rooted :
http://my.opera.com/wiz/blog/2009/06/16/how-to-install-japanese-ime-on-android
You need to log in before you can comment on or make changes to this bug.