fill() does not fill whole path consisting of bezierCurveTo() and quadraticCurveTo() (cairo path)

RESOLVED DUPLICATE of bug 1063486

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1063486
7 years ago
3 years ago

People

(Reporter: u335068, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0

Some paths consisting of bezierCurveTo() and quadraticCurveTo() won't get filled completely. Sometimes they even won't get outstroked correctly like in the provided case.

Reproducible: Always

Steps to Reproduce:
1. load the provided website/html file
2. observe non-complete filling

Actual Results:  
The top part of the figure is not filled red. Also the blue stroke is not closed on top.

Expected Results:  
The whole figure should be filled and stroked (works with Opera, Chrome and IE9).

Further testing with isPointInPath() showed that Firefox correctly distinguishes the path, but it just does not draw it right.
(Reporter)

Comment 1

7 years ago
Created attachment 539457 [details]
Live example of the described bug
(Reporter)

Comment 2

7 years ago
Created attachment 539458 [details]
screenshot of incomplete fill() (and stroke()) in FF5
(Reporter)

Updated

7 years ago
Attachment #539457 - Attachment mime type: text/plain → text/html

Comment 3

7 years ago
Reproducible on (latest Nightly):
-> Windows XP: Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110614 Firefox/7.0a1
-> Ubuntu 11.04: Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110615 Firefox/7.0a1

WHILE it Works for me on (latest Nightly):
-> Windows 7: Mozilla/5.0 (Windows NT 6.1; rv:7.0a1) Gecko/20110614 Firefox/7.0a1
-> Max OS 10.6: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0a1) Gecko/20110614 Firefox/7.0a1

*Setting status to NEW on Windows XP
Status: UNCONFIRMED → NEW
Ever confirmed: true
Given comment 3, it sounds like it works with D2D and CoreGraphics path rendering but fails with cairo path rendering....
Component: Canvas: 2D → Graphics
QA Contact: canvas.2d → thebes
Summary: fill() does not fill whole path consisting of bezierCurveTo() and quadraticCurveTo() → fill() does not fill whole path consisting of bezierCurveTo() and quadraticCurveTo() (cairo path)
Version: unspecified → Trunk

Comment 5

7 years ago
This is still reproducible in Firefox 10 on Ubuntu 11.04.

Comment 6

6 years ago
Regression window(with HWA off)
Cannot reproduce:
http://hg.mozilla.org/mozilla-central/rev/2968d19b0165
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100426 Minefield/3.7a5pre ID:20100426040533
Can reprodce:
http://hg.mozilla.org/mozilla-central/rev/f236632a9747
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100426 Minefield/3.7a5pre ID:20100426084628
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2968d19b0165&tochange=f236632a9747

Triggered by:
f236632a9747	Jeff Muizelaar — Bug 542605. Update cairo to 12d521df8acc483b2daa844d4f05dc2fe2765ba6. r=vlad,jwatt,bas Reland after fixing quartz related clipping bug and a bunch of other ones

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1063486
You need to log in before you can comment on or make changes to this bug.