Last Comment Bug 664430 - Make sure PopupManager doesn't keep objects alive after xpcom-shutdown
: Make sure PopupManager doesn't keep objects alive after xpcom-shutdown
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: unspecified
: x86_64 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Olli Pettay [:smaug]
:
Mentors:
Depends on:
Blocks: strongparent 480191
  Show dependency treegraph
 
Reported: 2011-06-15 08:00 PDT by Olli Pettay [:smaug]
Modified: 2011-06-20 13:58 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (4.09 KB, patch)
2011-06-15 08:00 PDT, Olli Pettay [:smaug]
enndeakin: review+
Details | Diff | Splinter Review

Description Olli Pettay [:smaug] 2011-06-15 08:00:52 PDT
Created attachment 539520 [details] [diff] [review]
patch

This is not about fixing any real runtime leak, but only to make sure the
objects aren't kept alive on shutdown.
Comment 1 Neil Deakin 2011-06-15 08:09:03 PDT
There's bug 480191 which suggests more of a cycle collector thing.
Comment 2 Olli Pettay [:smaug] 2011-06-15 08:22:01 PDT
Nothing there suggest a cycle collector thing. Peter just says that something
should break the cycle, and the patch in this bug does that.
Comment 3 Olli Pettay [:smaug] 2011-06-15 08:22:46 PDT
But I'll verify if I can reproduce the leak with the patch.
Comment 4 Olli Pettay [:smaug] 2011-06-15 08:24:25 PDT
At least with the patch I can't reproduce the leak.
Comment 5 Olli Pettay [:smaug] 2011-06-15 13:32:47 PDT
And actually, since popupmanager is a singleton which will stay alive
until shutdown, adding traverse/unlink is effectively the same as
releasing member during xpcom-shutdown.
Comment 6 Olli Pettay [:smaug] 2011-06-18 02:40:55 PDT
http://hg.mozilla.org/mozilla-central/rev/cbd6b39597c6

Note You need to log in before you can comment on or make changes to this bug.