Last Comment Bug 664455 - Traverse/Unlink contentsink some more
: Traverse/Unlink contentsink some more
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: x86_64 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Olli Pettay [:smaug]
:
Mentors:
Depends on:
Blocks: strongparent
  Show dependency treegraph
 
Reported: 2011-06-15 09:02 PDT by Olli Pettay [:smaug]
Modified: 2011-06-18 02:40 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.32 KB, patch)
2011-06-15 09:02 PDT, Olli Pettay [:smaug]
hsivonen: review+
Details | Diff | Review

Description Olli Pettay [:smaug] 2011-06-15 09:02:28 PDT
Created attachment 539553 [details] [diff] [review]
patch

I don't have a testcase for possible leak, but while going through some 
other code, this looked a bit suspicious.
Comment 1 Henri Sivonen (:hsivonen) 2011-06-16 02:37:11 PDT
Comment on attachment 539553 [details] [diff] [review]
patch

r=me provided that you have another in-flight patch that makes nsScriptLoader a CC participant.

(Aside: It's very sad that this stuff touches the content sink in the first place. I want to get rid of mScriptElements and move the parser blocking logic entirely to the script loader, but so many other things to do...)
Comment 2 Olli Pettay [:smaug] 2011-06-16 05:23:27 PDT
uh, I don't have such. Good that you noticed, since scriptloader sure should be
CC-able.
Comment 3 Olli Pettay [:smaug] 2011-06-18 02:40:06 PDT
http://hg.mozilla.org/mozilla-central/rev/bd8214b3bcaf

I'll fix the followup bug soon.

Note You need to log in before you can comment on or make changes to this bug.