If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add list of domains (sites) that trigger private browsing automatically

RESOLVED WONTFIX

Status

()

Firefox
Private Browsing
--
enhancement
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: Neal Burns, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

It would be useful to have the option of creating a list of domains that automatically trigger private browsing mode. For instance, if you belong to an online support group, you could add that domain to the list so that you would never accidentally visit that site with PB turned off. Or, it could be set up just to ask if you want PB.

You could argue that having a list of private sites would defeat the purpose of private browsing, since somebody else could access the list. But it would at least prevent someone from accidentally stumbling on the history for that domain. They would have to be deliberately trying to snoop.

Reproducible: Always
This would depend on Bug 463027 first, no?
OS: Windows 7 → All
Hardware: x86 → All
Version: unspecified → Trunk
(Reporter)

Comment 2

6 years ago
(In reply to comment #1)
> This would depend on Bug 463027 first, no?

Not necessarily. Although, you would probably want it to ask before closing or doing anything to other windows.
I don't think this something that we would want to see in the core Firefox browser.  Once bug 463027 is fixed, an add-on can do this relatively easy though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Depends on: 463027
Resolution: --- → WONTFIX

Updated

2 years ago
Duplicate of this bug: 1213692
You need to log in before you can comment on or make changes to this bug.