The Launch Application dialogue after clicking a magnet: link does not work with Transmission

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
8 years ago
5 years ago

People

(Reporter: jesaja53+moz, Unassigned, NeedInfo)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110613 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110613 Firefox/7.0a1

When you click on a magnet: URL, you are presented with a dialogue asking what application you want to open it with. Choosing Transmission, the default torrent app in Ubuntu renders the Ok button unusable. Clicking it depresses it, but then nothing happens.

Reproducible: Always

Steps to Reproduce:
1. Click on a magnet: URL
2. Select transmission
3. Click OK

Actual Results:  
Nothing happens. The Launch Application dialogue does not go away or change in any way.

Expected Results:  
Launch Application dialogue closes and Transmission is opened, asking you where to save the torrent.

In addition to this "transmission" is spelled with a lower case "t", even though its name is "Transmission".
What window manager? In general Whttp://kb.mozillazine.org/Register_protocol though there are known issues with gtk3 at this time.
(Reporter)

Comment 2

8 years ago
Thanks for your very fast reply! I'm using a standard installation of Ubuntu 10.10. So Gnome 2.

Comment 3

8 years ago
Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110615 Firefox/7.0a1

Just tried reproducing your issue and was unable. After selecting the link, a small window pops-up letting me chose with what application should the torrent file be opened. Selecting Transmission, opens the application as expected.

What I can confirm is that Trasmission is written with a "t" instead of a "T".
Version: unspecified → Trunk
(Reporter)

Comment 4

7 years ago
I just tried it again with the latest Nightly, with the exact same result as every other time I've tried. This goes back to Firefox 4, and older versions of Ubuntu for me.
Are you still seeing this issue? If so, please provide the Firefox version you are using and a new URL, since the old one doesn't seem to load anymore. (I get the "Unable to connect" error)
Flags: needinfo?(jesaja53+moz)
Marking incomplete due to lack of response.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.