Closed Bug 66460 Opened 20 years ago Closed 20 years ago

"Check for new mail at startup" pref should be turned on by default for first account (i.e., default account)

Categories

(SeaMonkey :: MailNews: Account Configuration, defect, P2)

defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9

People

(Reporter: sheelar, Assigned: racham)

References

Details

(Whiteboard: [nsbeta1+])

Attachments

(2 files)

As per the spec (get message and log in to account at startup) the first account
setup or account migrated first will have the preference "log on to this account
on the start up of mail" should have it turned on by default.
Steps to produce:
(build 2001-01-24-09 on windows)
Create a new profile
Create pop or imap account
Actual Result: You get the password dialog to log on to that account. But when
you look at the accounts settings the pref "log on to this account on the start
up of mail" is not turned on meaning the check box is not checked.
Expected Result:  Based on our issues meetings and the spec this pref is checked
by default
change qa contact to nbaca, cc esther.
Ninoschka,
I think this pref item is your area.  If not please reassign.
QA Contact: esther → nbaca
Status: NEW → ASSIGNED
Keywords: nsbeta1
Priority: -- → P2
Target Milestone: --- → mozilla0.8
Recommend WONTFIX.

Most POP users are on dialup (with time-based billing), and are likely to read
mail offline. Logging in at startup will do that wrong thing. If a user has a
permanent connection (which are probably < 50%, remember countries outside USA),
he can enable the pref.
OS: Windows 98 → All
Hardware: PC → All
CCing myself...
From our specs (http://www.mozilla.org/mailnews/specs/threepane/GetMail.html) :

"The default account (the account setup first or the account migrated first)
will have the setting turned on by default."

Remember the condition mentioned here...turned on by default only if it is the
first account.

The user always should be given the flexibility of controlling this behavior
later via checking/unchecking this pref for any given account i.e., Obey the
pref always.

If the user unchecks this pref even for the default account, then on startup, We
won't login but select the  account (not the Inbox) & display the accountcentral
page for that instead.

For the other accounts, if he/she unchecks this pref, we simply don't log onto
those accounts....that's all.
As outlined above, this will cause us to error, if Mailnews is started with
offline network connection, which will happen for the majority of users quite
often. So, why should we default to that? (The "the user can always change it"
also applies in the opposite direction.)

The fact that it's only for the default account doesn't matter much: The user
will get an error.
marking nsbeta1+
Whiteboard: [nsbeta1+]
moving to mozilla0.9.  Let's keep this open for discussion.  It looks like we
aren't going to put biff on by default for POP so it might be good to turn this
off by default.  Jennifer, in the usability studies that you did, I think you
mentioned that people expected their new mail to just be there.  Do you think
not turning this on by default (and thereby not downloading their new mail at
startup) will be a problem. Or do you think that things like Account Central
make it easier for people to realize what they need to do to get their mail?  
Target Milestone: mozilla0.8 → mozilla0.9
I think Acct Central will help with the problems we saw. The big problem was 
people starting up mail and seeing a blank Thread/Message pane (Acct Level 
selected by default) and not being quite sure what to do next to see their mail. 
 People clicked the "Get Msg" button but that didn't help either (since the Acct 
Level was still selected).  Now with Acct Central, users can click the "Read my 
messages" item and see their Inbox. I'm assuming clicking "Read my messages" 
will pull new messages? 
> I'm assuming clicking "Read my messages" will pull new messages?

IIRC, this was the plan, yes. If it doesn't, file a bug.

> If it doesn't, file a bug.

Or use bug 66376.
Build 2001-02-08-08: NT4
The spec does not specifically state whether Logon At Startup should be a
default, even though the screenshots show that this option is always selected. 
The latest I've heard is that it should work in the following way:

AccountType:     Logon At Startup:
POP              Not selected for default and additional POP accounts
IMAP             Selected for default and additional IMAP accounts

Actual Results:
- POP: works as expected. It is not selected for the default or additional
account. If the user does select this option then the login prompt appears and
messages are retrieved.

- IMAP: the option is not selected for the default account or additional
accounts. According to the above matrix it should be selected in all cases.
(note: If the user selects the option then it does work)
Ninoschka,

It's off by default for all new accounts now. But as mentioned by you, it should
be 'off' for POP accounts and 'on' for IMAP accounts.

Today, when the user clicks 'Read my mail messages', unfortunately, we only
selct the inbox and don't try to get new messages. Getting messages is triggered
automatically for IMAP accounts though. It's for POP account that we need to
trigger Get Messages explicitely. As Jennifer said, we should attempt to get new
messages...!! I will open a new bug on this one.
For IMAP, it makes more sense. No objectione from me.

Should we close as WONTFIX?
I'd like to keep this open to track the default IMAP behavior.

The pref should be selected for IMAP accounts by default but the problem is that 
it currently is not.
Oh, overlokked that. Change summary (to only apply to IMAP)?
Changed summary " 'Log onto this account at start up of Mail' pref should be
turned on by default for the first IMAP account".

Note: Additional IMAP accounts will have this pref turned off.
Summary: "Log on to this account at start up of mail" pref should be turned on by default → "Log on to this account at start up of mail" pref should be turned on by default for first IMAP account
Since Account Central landed, access to mail has changed dramatically from the 
way it has been accessed in all prior versions of Netscape and Mozilla in 
recent memory. Clicking the component icon has always meant Start Mail and 
Check for New Messages. The change away from this has caused confusion and 
frustration as the Account Central page, which IIRC was designed to appear when 
a toplevel folder was selected, now appears when the mail client starts. Adding 
insult to injury, there is a brief period (in debug builds at least) where the 
3pane appears and then disappears, which looks terrible.

I have a few suggestions:

- Consolidate this start page with the mail start page preference described in 
Preferences->Mail and News. This then becomes the generic start page. 
- Place a checkbox on the start page that says something like "don't show 
again" or "check my mail at startup" or something like that. I wouldn't mind 
the page coming up first if there was a way that I could get rid of it easily 
(without having to dig through trillions of dialogs) and never have to see it 
again unless I unset the pref in preferences or clicked on a toplevel folder. 

The reason people load mailnews is to check mail. Adding levels of indirection 
between the user and his mail is slowing them down. There may be a novice user 
benefit to doing this, but please, PLEASE make it easy to get rid of for 
everyone else. 
> Since Account Central landed, access to mail has changed dramatically from
> the way it has been accessed in all prior versions of Netscape and Mozilla
> in recent memory.

Oh, I didn't realize that this was related to this bug.

If I leave Mailnews with INBOX selected, I expect Mailnews to have INBOX
selected after relaunch.

I thought, the "Check new mail at startup" pref would really only do this,
instead, it also changes which "folder" is selected. This is not ovious and IMO
wrong.

(My personal opinion is that the last folder, no matter which one, should be
remembered, but I hasve been overruled.)

> The reason people load mailnews is to check mail.

No, not necessarily. Maybe they just want to look up in the archive or want to
read mail offline.
I strongly disagree with selecting the last folder you visited.  It's very easy
to shut down in a different folder than the one you want to start up with.  I'm
always going to want to start up in my Inbox and I expect most users will too.

The reason the behavior that Ben Goodger mentions started occuring is because we
fixed it so that we don't automatically get mail for POP accounts if Log on to
this account at start up isn't selected on the default account.

Perhaps we should make some assumptions?  Regardless of whether the user has log
on selected I think we should select the default Imap folder (this has the side
effect of getting mail and I don't think this is a bad thing).  If the user has
a default POP account then it should always go to the Inbox.  If log on is
checked for this account then it should log on and get new mail.

I'm not a big fan of having different behaviors for POP and IMAP but it seems
that we are getting a lot of resistance about getting mail by default for
default POP accounts whereas I think this is expected for default IMAP accounts.

Any opinions/suggestions? If I have time I'll start a discussion in the
newsgroup today.
FYI: The problem with the start page appearing/disappearing is logged in bug#
68345. Do a query on "Account Central" and you'll find a variety of bugs reported.
i couldn't agree more. checking mail now is just frustrating with the extra step 
thrown in.
> Regardless of whether the user has log on selected I think we should select
> the default Imap folder (this has the side effect of getting mail and I don't
> think this is a bad thing).  If the user has a default POP account then it
> should always go to the Inbox.  If log on is checked for this account then
> it should log on and get new mail.

IMO, that would be fine. (YMMV.)
The purpose of Account Central shouldn't be to make things harder, or make extra 
steps for people. The purpose is to use the right pane for something useful when 
an Account Level item is selected instead of leaving it blank as it used to. 
Especially if less experienced users end up with the account level selected by 
accident (or curiosity), we show them something useful.

When mail is first started up (for the first usage or subsequent usage) the 
Inbox of the default account should be selected. When the default account is 
setup, if its an IMAP account, "Log onto this account at startup" is turned on. 
When additional IMAP accounts are added, "Log onto this account at statup" is 
not turned on by default (to avoid the user getting hit with multiple dialogs by 
default).  If a POP account is first account setup (hence the default), I would 
also like to see the "Log onto this account at startup" on by default. But in 
another bug, it seemed like folks didn't like that idea.  OK by me.  Additional 
POP accounts do not have "Log onto..." turned on by default.
*** Bug 69487 has been marked as a duplicate of this bug. ***
missed am-top-server.dtd change. Reposting the patch after appending that one.
Attached patch Complete patchSplinter Review
After series of discussions on the startup behavior, the following changes have
been implemented in the patch (id=25867).

* Rephrase the option 'Log onto this account at startup of Mail' to 'Check for
new mail at startup'. To the effect of the meaning of rephrased option, we now
check for the new mail, instead of getting new mail.

* When the option is checked we perform biff on those accounts to check for new
mail. All IMAP accounts get message headers with biff icons and POP accounts are
showed with biff icons if there are new messages. New messages on POP accounts
are not downloded until GetMsg button is clicked. 

* Prior to mozilla0.8 builds, we never had the (checkbox) option 'Logon to this
account at startup of Mail' (now renamed as mentioned above). Then we introduced
this option (off by default). So, when the user starts mail app, in case of
default account, it checks the status of this option. If the option is 'on', the
Inbox of that account is opened and starts getting new messages for that
account. If the option is 'off', we selected the account name in the folder pane
and hence AccountCentral page is presented on the righthand side. This created
problem for many users (who created accounts when this option didn't even exist)
as they are used to go to Inbox directly and instead landed in AccountCentral
page. From the AccountCentral they had to click on 'Read Messages' to go Inbox.
So, it essentially added one more step on the way to Inbox. So, in order to
solve this problem, this patch enables the option *just once* to check mail at
startup, so that the default account goes to Inbox like it used to be. Once the
Inbox is selected, a check for new mail performed (biff). This option is enabled
once only so that all get the behavior that has expected widely i.e., go to
inbox directly. Those users who like the AccountCentral page can always go to
the server panel and turn the option.

* Every newly created/migrated first account (IMAP and POP), considered as
default account, will have this option turned 'on'. Any additional accounts
(IMAP or POP) will have this option turned 'off'.

* On startup, check for new mail is performed (i.e., perform biff) on all 
accounts that have this option turned 'on'. Default account, with this option
'on', is twisty-opened if needed and Inbox is selected before the check for new
mail is done.

Please bring forward any issues or questions you may have. Thanks.

Adding Seth, Bienvenu, ScottP and Kevin to the cc list.
Adding patch and review keywords.
Keywords: patch, review
Changing summary from 

"Log on to this account at start up of mail" pref should be turned on by default
for first IMAP account

to 

"Check for new mail at startup" pref should be turned on by default for first
account (i.e., default account)
Summary: "Log on to this account at start up of mail" pref should be turned on by default for first IMAP account → "Check for new mail at startup" pref should be turned on by default for first account (i.e., default account)
r=bienvenu
bhuvan, thanks for the great summary.  I'll update the spec to reflect this.
http://www.mozilla.org/mailnews/specs/threepane/GetMail.html
Fixed. Thanks for reviews.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Build 2001-03-06-05: NT4, Mac 9.04
Build 2001-03-06-08: Linux RH 6.2

In Most cases the "Check for new mail at startup" pref was selected by default
for the first account. Only one case on the Mac failed.

1. Migrated IMAP
2. Migrated POP
3. New Profile, activate WebMail (this failed on the Mac)
4. New Profile, IMAP added w/ account wizard
5. New Profile, POP added w/ account wizard
6. New Profile, WebMail added w/ account wizard
7. New Proifile, AOL added w/ account wizard

Should I log a separate bug for the Mac issue?
please. I think that would be better than reopening this bug.
Verified Fixed. 

Logged bugscape# 4184 to track Netscape WebMail Activation problem.


Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.