Last Comment Bug 664778 - add distributions/ to removed-files.in
: add distributions/ to removed-files.in
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-16 11:01 PDT by Ben Hearsum (:bhearsum)
Modified: 2011-06-16 12:22 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
remove distribution dir when not packaging testpilot (724 bytes, patch)
2011-06-16 11:01 PDT, Ben Hearsum (:bhearsum)
robert.strong.bugs: review+
bhearsum: checkin+
Details | Diff | Splinter Review

Description Ben Hearsum (:bhearsum) 2011-06-16 11:01:38 PDT
Created attachment 539829 [details] [diff] [review]
remove distribution dir when not packaging testpilot

This directory houses the testpilot extension, when channel == beta or aurora. We already add testpilot to removed-files when the channel is something different, we should this directory, too.

:rs told me that we should drop searchplugins/ from the list as a ridealong, because it's no longer empty.
Comment 1 Benjamin Smedberg [:bsmedberg] 2011-06-16 11:35:15 PDT
I don't think this is right *at all*! We don't just use this for testpilot, Wouldn't we would be blowing away all the custom partner builds on update, which is very very bad.
Comment 2 Robert Strong [:rstrong] (use needinfo to contact me) 2011-06-16 11:38:04 PDT
Entries in removed-files.in that end with a slash will only be removed if they are a directory and the directory is empty. Entries that end with /* will be removed recursively.

Signed,
actually knows this stuff ;)

Note You need to log in before you can comment on or make changes to this bug.