Rename several WebSockets classes/IDLs to match necko conventions before we ship WS

RESOLVED FIXED in mozilla7



8 years ago
8 years ago


(Reporter: jduell.mcbugs, Assigned: jduell.mcbugs)



Firefox Tracking Flags

(Not tracked)


(Whiteboard: [inbound])


(4 attachments)



8 years ago
Right now the network transport for Web sockets is called nsIWebSocketProtocol.idl, and it's implemented by the nsWebSocketHandler class.

Everywhere else in necko we reserve "Protocol" and "Handler" for singleton, protocol-wide classes (see nsHttpHandler, nsFtpProtocolHandler, both of which inherit from nsIProtocolHandler.idl).  So this is needlessly confusing.

We should rename 

   nsIWebSocketProtocol -> nsIWebSocketChannel
   nsWebSocketHandler   -> WebSocketChannel

I'd especially like to see the IDL change before we ship WS for the first time, so we don't need to break XPCOM interfaces.

Comment 2

8 years ago
Attachment #543637 - Flags: review?(mcmanus)

Comment 3

8 years ago
E10s classes are already named WebSocketChannelChild, etc.
Assignee: nobody → jduell.mcbugs
Attachment #543638 - Flags: review?(mcmanus)

Comment 4

8 years ago
Re-indent WebsocketChannel. It's now or never--we don't want to do this after the Aurora branch.

Contains some cleanup of LOG msgs too.
Attachment #543639 - Flags: review?(mcmanus)

Comment 5

8 years ago
I've assigned these to Patrick, but there's actually no code logic changes here, so pretty much anyone can review.  I'd really like to land them before we fork for Aurora.  If anybody's got time to glance over them (just lots of class renaming) I'd appreciate it.

We don't have a backlog of WS patches right now, so patch breakage isn't an issue. The most "interesting" decision here is that we'll lose the hg blame for WebSocketChannel with the last, re-indent patch.  But the hg log is pretty short now, so I'm not seriously worried about it.
Attachment #543636 - Flags: review?(mcmanus) → review+
Attachment #543637 - Flags: review?(mcmanus) → review+
Attachment #543638 - Flags: review?(mcmanus) → review+
Attachment #543639 - Flags: review?(mcmanus) → review+
You need to log in before you can comment on or make changes to this bug.