Last Comment Bug 664898 - Cleanup startup cache api
: Cleanup startup cache api
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Michael Wu [:mwu]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-16 17:37 PDT by Michael Wu [:mwu]
Modified: 2011-07-20 07:01 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Kill NS_ prefix, move using out of header (13.05 KB, patch)
2011-07-18 21:46 PDT, Michael Wu [:mwu]
taras.mozilla: review+
Details | Diff | Splinter Review

Description Michael Wu [:mwu] 2011-06-16 17:37:19 PDT
From taras in bug 592943:

This kind of unrelated to the patch. But while you are at this can you get rid of NS_* prefix in this file? and Get rid of the using namespace mozilla::scache(didn't realize it was in a header too :( ) in mozJSComponentLoader?

also rename scache->startupcache and make all calls via the namespace ie

startupcache::PathifyURI.
Comment 1 Michael Wu [:mwu] 2011-07-18 21:46:29 PDT
Created attachment 546708 [details] [diff] [review]
Kill NS_ prefix, move using out of header

This implements the first two suggestions. I'm a bit suspicious of doing scache->startupcache since that's pretty verbose and requiring the namespace every time makes it even worse. Lines like:

StartupCache* cache = StartupCache::GetSingleton();

would turn into 

startupcache::StartupCache* cache = startupcache::StartupCache::GetSingleton();

Though I think just doing scache->startupcache without removing the use of using would be ok.
Comment 3 Marco Bonardo [::mak] 2011-07-20 07:01:28 PDT
http://hg.mozilla.org/mozilla-central/rev/a9f847216e1f

Note You need to log in before you can comment on or make changes to this bug.