From taras in bug 592943:
This kind of unrelated to the patch. But while you are at this can you get rid of NS_* prefix in this file? and Get rid of the using namespace mozilla::scache(didn't realize it was in a header too :( ) in mozJSComponentLoader?
also rename scache->startupcache and make all calls via the namespace ie
Created attachment 546708 [details] [diff] [review]
Kill NS_ prefix, move using out of header
This implements the first two suggestions. I'm a bit suspicious of doing scache->startupcache since that's pretty verbose and requiring the namespace every time makes it even worse. Lines like:
StartupCache* cache = StartupCache::GetSingleton();
would turn into
startupcache::StartupCache* cache = startupcache::StartupCache::GetSingleton();
Though I think just doing scache->startupcache without removing the use of using would be ok.