Please add NTO Platform and OS and possible Photon GUI if such a place exists

VERIFIED FIXED in Bugzilla old

Status

()

Bugzilla
Bugzilla-General
P3
minor
VERIFIED FIXED
19 years ago
5 years ago

People

(Reporter: Jerry.Kirk, Assigned: Terry Weissman)

Tracking

unspecified
Bugzilla old
Other
Other

Details

(Assignee)

Description

19 years ago
I don't know what "NTO" or "Photon" mean.  Can you elaborate?
(Reporter)

Comment 1

19 years ago
Sorry for the misunderstanding, NTO stands for Neutrino a new operating system by QSSL which also makes QNX, all these are UNIX variants. Photon is a GUI which runs on Neutrino and QNX much like GTK or Motif run on Linux, but it is not based on X-Windows. My team has been working for several months to port Mozilla to Neutrino/Photon.
(Assignee)

Comment 2

19 years ago
OK, this seems very cool.

I think I understand that you want a new field to the OS.  That's cool.  Can you
tell me exactly what value you think it ought to say?  The less cryptic, the
better, but it can't be very long either...

I don't think you really want me to add to the Platform list.  That is a list of
hardware platforms.  Are you running on some kind of new hardware, or existing
PCs?

I could add a "Photon GUI" component, for bugs relating only to the GUI
implementation, if that would be useful to you.
(Reporter)

Comment 3

19 years ago
Hmmm, I am not sure what we should do. The problem is Hardware != OS != GUI  Neutrino is currently on x86 PC hardware but is scheduled soon for 2 other CPU arhitectures, QNX is however limited to PC (x86). Neutrino can run Motif with X-Windows as well as the Photon GUI. After we finish with the Photon port we *may* go back and support Mozilla under GTK+ under Neutrino. This issue is fairly easy for Windows 9x but not for Windows NT which could be x86 or Alpha. The same problem applies to Linux, there are lots of possible combinations.

I was surprised not to see GUI as a drop down list, but to be fair you would have to make platform, os, and gui multi-select lists because bugs may fall into many categories.

All that said and done why don't you just add "Neutrino" to the OS list and we can hash it out if it doesn't serve all of our interests.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

19 years ago
Right, Hardware != OS, which is why there are separate "Platform" and "OS"
dropdowns.

I have added Neutrino to the OS list.
Terry, here's another badly converted bug.

Verif.
Status: RESOLVED → VERIFIED
QA Contact: matty
Moving to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Target Milestone: --- → Bugzilla old
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.