Last Comment Bug 664969 - xpfe should use mozilla::Preferences
: xpfe should use mozilla::Preferences
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XP Toolkit/Widgets: XUL (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured)
:
Mentors:
Depends on: 656826
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-17 03:22 PDT by Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured)
Modified: 2011-06-20 08:52 PDT (History)
2 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1.0 (10.05 KB, patch)
2011-06-17 03:22 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured)
neil: review+
Details | Diff | Review

Description Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2011-06-17 03:22:02 PDT
Created attachment 540022 [details] [diff] [review]
Patch v1.0
Comment 1 neil@parkwaycc.co.uk 2011-06-17 05:11:08 PDT
Comment on attachment 540022 [details] [diff] [review]
Patch v1.0

>+  if (!Preferences::GetRootBranch()) {
>+    return NS_ERROR_FAILURE;
>+  }
Don't need this, Preferences::GetInt null-checks sPreferences.
r=me with that fixed.

>+  rv = Preferences::GetInt("network.dir.format", &dirPref);
>   if (NS_SUCCEEDED(rv) && dirPref == FORMAT_XUL) {
In fact, you could probably simplify this to
if (Preferences::GetInt("network.dir.format") == FORMAT_XUL)
Comment 2 Masayuki Nakano [:masayuki] (Mozilla Japan) (working slowly due to injured) 2011-06-19 20:01:47 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/1653c994c505
Comment 3 Mounir Lamouri (:mounir) 2011-06-20 08:52:23 PDT
Merged:
http://hg.mozilla.org/mozilla-central/rev/1653c994c505

Note You need to log in before you can comment on or make changes to this bug.