Closed Bug 664986 Opened 10 years ago Closed 10 years ago

Fix random timeouts in livemarks tests

Categories

(Toolkit :: Places, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla7

People

(Reporter: mak, Assigned: mak)

References

Details

(Whiteboard: [fixed-in-places])

Attachments

(1 file)

From some logging I got on try it seems to be caused by idle, when the user is idle from more than 30 minutes we stop updating livemarks, sometimes the tinderboxes are idle from more than 30 minutes and livemarks tests timeout.
This patch makes sure tests use forceUpdate APIs rather than the common start() call, and fixes reloadAllLivemarks to use the lazy loading stuff rather than a simple loop so I can use it instead of start() in tests (there is another bug about the fact reloadAllLivemarks hangs everything for minutes, so this may even fix that).
Attached patch patchSplinter Review
Notice this is blocking next Places merge since currently tree has orange due to this
Attachment #540049 - Flags: review?(dietrich)
Blocks: 303567
Blocks: 561007
Comment on attachment 540049 [details] [diff] [review]
patch

Review of attachment 540049 [details] [diff] [review]:
-----------------------------------------------------------------

looks fine, r=me
Attachment #540049 - Flags: review?(dietrich) → review+
http://hg.mozilla.org/projects/places/rev/6604c07b0de4
Whiteboard: [fixed-in-places]
http://hg.mozilla.org/mozilla-central/rev/6604c07b0de4
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla7
You need to log in before you can comment on or make changes to this bug.