Last Comment Bug 664996 - After quitting the application by tapping the Home button, re-entering it will show a black screen
: After quitting the application by tapping the Home button, re-entering it wil...
Status: VERIFIED FIXED
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: -- major (vote)
: Firefox 6
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 661843
  Show dependency treegraph
 
Reported: 2011-06-17 07:35 PDT by Anna (Waverley)
Modified: 2011-06-27 17:35 PDT (History)
13 users (show)
mounir: in‑testsuite?
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix redraw-scheduling on first draw (1.31 KB, patch)
2011-06-17 08:40 PDT, Chris Lord [:cwiiis]
dougt: review+
Details | Diff | Review
Fix redraw handling on first draw after surfaceChanged (2.73 KB, patch)
2011-06-21 18:23 PDT, Chris Lord [:cwiiis]
dougt: review+
dougt: approval‑mozilla‑aurora+
Details | Diff | Review

Description Anna (Waverley) 2011-06-17 07:35:37 PDT
Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110617 Firefox/7.0a1 Fennec/7.0a1 

Device: HTC Desire Z (Android 2.2)

Steps to reproduce:
1. Load Fennec.
2. Tap the Home Button to bring the application in background.
3. Tap the application's icon.

Actual results:
White screen is displayed. Please see the video: http://www.youtube.com/user/qaioana#p/u/0/t-203zqNzOU

Expected results:
The webpage or about:home should be displayed.
Comment 1 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2011-06-17 07:41:04 PDT
Confirmed, I can see it in today's trunk build, but yesterday's build didn't have this problem.
Comment 2 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2011-06-17 07:47:13 PDT
Also happening when tapping on the 'Back' button while being in the options.
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-06-17 07:48:37 PDT
(In reply to comment #2)
> Also happening when tapping on the 'Back' button while being in the options.

I don't see this part.

I _can_ see the white screen after tapping Home and coming back to the app.

FWIW, tapping on the white screen causes a redraw and all is well again.
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-06-17 07:49:35 PDT
Regression from bug 661843
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-06-17 07:50:07 PDT
(In reply to comment #4)
> Regression from bug 661843

Missed the "?" - That was a question, not a statement
Comment 6 Chris Lord [:cwiiis] 2011-06-17 08:18:35 PDT
I think it may be and I have a patch that possibly fixes it, just testing and will attach when it's done (if it does fix it...)
Comment 7 Chris Lord [:cwiiis] 2011-06-17 08:40:23 PDT
Created attachment 540059 [details] [diff] [review]
Fix redraw-scheduling on first draw

Because I'd altered the way surface creation works, it was possible to have a null buffer in surfaceChanged while having a valid surface size.

Instead of looking at the buffer pointers, I've replaced it with a boolean that tracks whether the surface size is valid or not. This fixes the issue for me.
Comment 9 Mounir Lamouri (:mounir) 2011-06-18 09:39:04 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/0839c57106a8
Comment 10 Anna (Waverley) 2011-06-20 05:35:21 PDT
Now, after tapping Home and coming back to the app, I can see a black screen. Was the changeset pushed to the pushlog? 

Build ID:Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110620 Firefox/7.0a1 Fennec/7.0a1

Device: HTC Desire Z (Android 2.2)
Comment 11 Mark Finkle (:mfinkle) (use needinfo?) 2011-06-20 07:01:22 PDT
(In reply to comment #10)
> Now, after tapping Home and coming back to the app, I can see a black
> screen. Was the changeset pushed to the pushlog? 

I see the same on a Nexus One
Comment 12 Chris Lord [:cwiiis] 2011-06-20 07:10:14 PDT
Ok, I'll have to test this on my HTC Desire (works for me on the Xoom, but I guess that's quite different).
Comment 13 Chris Lord [:cwiiis] 2011-06-21 16:56:32 PDT
Not sure what's happened, but I can always reproduce this on my Xoom now... Wondering if something else has changed in the meantime.

Looking at what happens, we create the surface fine, we get the surfaceChanged signal fine and we schedule the redraw fine - but the redraw doesn't happen. Am looking into this...
Comment 14 Chris Lord [:cwiiis] 2011-06-21 18:03:49 PDT
Typical, the real cause for this is a typo. Will attach a revised patch in a mo.
Comment 15 Chris Lord [:cwiiis] 2011-06-21 18:23:47 PDT
Created attachment 540939 [details] [diff] [review]
Fix redraw handling on first draw after surfaceChanged

Here's the udpated patch, along with a commit message. The typo was causing the synchronised draw scheduled in surfaceChanged to be ignored, so nothing was being painted at all.
Comment 16 Doug Turner (:dougt) 2011-06-26 08:02:30 PDT
http://hg.mozilla.org/mozilla-central/rev/38f69296b20c
Comment 17 Doug Turner (:dougt) 2011-06-26 08:19:01 PDT
Comment on attachment 540939 [details] [diff] [review]
Fix redraw handling on first draw after surfaceChanged

required followup to bug 661843 which is already m-a approved.
Comment 19 Aaron Train [:aaronmt] 2011-06-27 06:29:51 PDT
Verified Fixed

Mozilla/5.0 (Android; Linux; armv7l; rv:7.0a1) Gecko/20110627 FIrefox/7.0a1 Fennec/7.0a1

Note You need to log in before you can comment on or make changes to this bug.