Last Comment Bug 665009 - Replace the retired Public Domain Dedication link with CC0 in SVG reftests
: Replace the retired Public Domain Dedication link with CC0 in SVG reftests
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla7
Assigned To: Jonathan Watt [:jwatt] (catching up after vacation)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-17 08:28 PDT by Jonathan Watt [:jwatt] (catching up after vacation)
Modified: 2011-08-24 07:18 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (436.33 KB, patch)
2011-06-17 08:32 PDT, Jonathan Watt [:jwatt] (catching up after vacation)
longsonr: review+
gerv: feedback+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] (catching up after vacation) 2011-06-17 08:28:07 PDT
Our public domain reftests link to http://creativecommons.org/licenses/publicdomain/ but that page says that that old dedication is retired in favor of CC0. We should update to CC0 as a more effective and less US-centric tool for dedicating to the public domain.
Comment 1 Jonathan Watt [:jwatt] (catching up after vacation) 2011-06-17 08:32:37 PDT
Created attachment 540057 [details] [diff] [review]
patch

Generated using:

find layout/reftests/svg -type f | xargs -I{} sed -i -e 's,http://creativecommons.org/licenses/publicdomain/,http://creativecommons.org/publicdomain/zero/1.0/,g' {}

and checked for sanity visually. This is big enough to make your eyes bleed, but the sooner we do it the less time for more tests using the defunct dedication page.
Comment 2 Robert Longson 2011-06-17 08:43:53 PDT
Comment on attachment 540057 [details] [diff] [review]
patch

I'm with the details provided Gerv's OK with the concept of the swap.
Comment 3 Robert Longson 2011-06-17 12:21:21 PDT
(In reply to comment #2)
> 
> I'm with the details provided Gerv's OK with the concept of the swap.

That should have said I'm OK with the details...
Comment 4 Gervase Markham [:gerv] 2011-06-21 02:03:56 PDT
Normally you can't change the licensing on things without asking the copyright holder - but what if the copyright holder has disclaimed all interest? Is it OK to replace their disclaimer of interest with a different disclaimer of interest? :-)

I don't mind too much either way. You can either switch them all over, or you can just start using the new dedication given here:
http://www.mozilla.org/MPL/license-policy.html
on new tests.

Gerv
Comment 5 Jonathan Watt [:jwatt] (catching up after vacation) 2011-06-21 02:10:29 PDT
Right, that's how I saw it.

(In reply to comment #4)
> http://www.mozilla.org/MPL/license-policy.html

Hmm, the "Page History" link on that page seems to be broken BTW.
Comment 6 Gervase Markham [:gerv] 2011-06-21 02:17:02 PDT
jwatt: that appears to be bug 619842.

Gerv
Comment 7 Jonathan Watt [:jwatt] (catching up after vacation) 2011-06-21 05:45:34 PDT
Ah, thanks.
Comment 9 Vlad [QA] 2011-08-24 06:40:00 PDT
Hi guys. How can I verify this?
Thanks.
Comment 10 Robert Longson 2011-08-24 07:18:32 PDT
It's not a functional change to Firefox. It's just a change to the text in the reftests. If I were you I wouldn't bother.

Note You need to log in before you can comment on or make changes to this bug.