Last Comment Bug 665014 - Selecting text in the GCLI output area is broken
: Selecting text in the GCLI output area is broken
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-17 09:11 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-01-13 10:37 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-06-17 09:11:01 PDT
The selection end seems to be fixed to the bottom of the page.
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-06-17 09:12:04 PDT
Marked as blocking GCLI-HELP because it's really annoying, but I've not checked if this affects the FF integration.
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-07-13 11:52:47 PDT
Workaround found:

    // Commenting this out is a quick workaround for bug 653140 but it probably
    // breaks the popup mechanism, however for now selection is more important
    // that popup.
    // this.element.addEventListener('mousedown', this.preventBlur, true);

See changeset c80dc66
Comment 3 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-08-18 09:51:50 PDT
Moving to block GCLI-FUTURE because we have a workaround

Note You need to log in before you can comment on or make changes to this bug.