Build failure with elfhack on gcc 4.5.2

RESOLVED DUPLICATE of bug 664366

Status

RESOLVED DUPLICATE of bug 664366
7 years ago
6 months ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
jrmuizel@ironman:~/ehsan/mozilla-central$ gcc --version
gcc-4.5.real (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2
Copyright (C) 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

jrmuizel@ironman:~/ehsan/mozilla-central$ ld --version
GNU ld (GNU Binutils for Ubuntu) 2.21.0.20110327
Copyright 2011 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License version 3 or (at your option) a later version.
This program has absolutely no warranty.
jrmuizel@ironman:~/ehsan/mozilla-central$ cat mozconfig-dbg 
OBJDIR=obj-ff-dbg
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/$OBJDIR

ac_add_options --enable-application=browser
ac_add_options --enable-debug
ac_add_options --disable-optimize
ac_add_options --disable-crashreporter
ac_add_options --disable-jemalloc

mk_add_options MOZ_MAKE_FLAGS='-j12 -s'

export MOZ_DEBUG_SYMBOLS=1
You're not giving the error message. But I guess you are hitting bug 664366.
(Reporter)

Comment 2

7 years ago
Yeah, looks like it (sorry, I had closed the shell when I was filing this bug!)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 664366

Updated

7 years ago
OS: Mac OS X → Linux

Updated

6 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.