Last Comment Bug 665260 - Store start time in sessionstore data
: Store start time in sessionstore data
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 7
Assigned To: Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
:
Mentors:
Depends on:
Blocks: 698274 902729
  Show dependency treegraph
 
Reported: 2011-06-17 22:10 PDT by Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
Modified: 2013-08-07 18:19 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v0.1 (3.73 KB, patch)
2011-06-20 14:35 PDT, Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
dietrich: review+
Details | Diff | Review

Description Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-06-17 22:10:45 PDT
I think it could be interesting to have this data for telemetry, even if it doesn't have any practical uses. To be clear, I mean total age, not uptime of current process.

The way we write sessionstore.js, it clobbers the file creation time stamp each write so we can't just extract it.

Dietrich, Taras - does this sound useful?
Comment 1 (dormant account) 2011-06-20 09:22:05 PDT
(In reply to comment #0)
> Dietrich, Taras - does this sound useful?

Yes.
Comment 2 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-06-20 14:35:05 PDT
Created attachment 540595 [details] [diff] [review]
Patch v0.1

Does the thing. Due to bug 665702, this data isn't exposed outside of the file.

I tested by checking the timestamp in sessionstore.js like so:

first startup with apptabs (no previous value):
  1308595047885
restart (session not resumed / just app tabs):
  1308595192604
restore previous session:
  1308595047885
  (the start time from previous session overwrites new value)
restart with resume_session_once=true:
  1308595047885
restart with startup.page=3 (aka restore):
  1308595047885
Comment 3 Dietrich Ayala (:dietrich) 2011-06-21 07:25:22 PDT
Comment on attachment 540595 [details] [diff] [review]
Patch v0.1

Review of attachment 540595 [details] [diff] [review]:
-----------------------------------------------------------------

looks a-ok, r=me.
Comment 4 :Ehsan Akhgari (out sick) 2011-06-21 15:09:48 PDT
http://hg.mozilla.org/mozilla-central/rev/05b7d31f72bb
Comment 5 Vlad [QA] 2011-06-22 05:07:02 PDT
How can this be verified? 
Thx

Note You need to log in before you can comment on or make changes to this bug.