Last Comment Bug 665273 - Crash [@ GetElement] or "Assertion failure: index >= 0,"
: Crash [@ GetElement] or "Assertion failure: index >= 0,"
Status: RESOLVED FIXED
[ccbr]
: assertion, crash, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Linux
: -- critical (vote)
: ---
Assigned To: general
:
Mentors:
: 663468 (view as bug list)
Depends on:
Blocks: jsfunfuzz 465980
  Show dependency treegraph
 
Reported: 2011-06-18 02:47 PDT by Gary Kwong [:gkw] [:nth10sd]
Modified: 2011-06-22 10:08 PDT (History)
6 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
stack (4.90 KB, text/plain)
2011-06-18 02:47 PDT, Gary Kwong [:gkw] [:nth10sd]
no flags Details

Description Gary Kwong [:gkw] [:nth10sd] 2011-06-18 02:47:42 PDT
Created attachment 540226 [details]
stack

(Array(2415838199)).reduceRight(function(){})

crashes js opt shell on JM changeset 9ff00d53b5a5 without any CLI arguments at GetElement and asserts js debug shell at Assertion failure: index >= 0,

May be related to bug 663468 or bug 664009 ?
Comment 1 Gary Kwong [:gkw] [:nth10sd] 2011-06-18 03:44:46 PDT
Also reproduces on TM changeset e59b1d2a2f79.
Comment 2 Gary Kwong [:gkw] [:nth10sd] 2011-06-18 06:30:50 PDT
autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   26356:7f7722d3a2dc
user:        Jeff Walden
date:        Mon Jan 12 13:07:48 2009 -0800
summary:     Bug 465980 - Some array methods don't work right on ginormous arrays.  r=brendan
Comment 3 Jeff Walden [:Waldo] (remove +bmo to email) 2011-06-19 18:00:48 PDT
I didn't land the fix for bug 664009 in TM, only in m-c and a bunch of beta and release branches.  I'm pretty sure this goes away with a m-c->TM merge.
Comment 4 Doug Turner (:dougt) 2011-06-21 13:53:38 PDT

*** This bug has been marked as a duplicate of bug 663468 ***
Comment 5 Doug Turner (:dougt) 2011-06-21 13:55:03 PDT
*** Bug 663468 has been marked as a duplicate of this bug. ***
Comment 6 Doug Turner (:dougt) 2011-06-21 13:56:00 PDT
sorry for the noise.
Comment 7 Gary Kwong [:gkw] [:nth10sd] 2011-06-22 10:08:29 PDT
(In reply to comment #3)
> I didn't land the fix for bug 664009 in TM, only in m-c and a bunch of beta
> and release branches.  I'm pretty sure this goes away with a m-c->TM merge.

Confirmed to be fixed in a later TM changeset 0428dbdf3d58.

Note You need to log in before you can comment on or make changes to this bug.