classic Mongolian script shaping problem

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: tugstugi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0

The harfbuzz library supports already classic Mongolian script through Arabic shaper. But Firefox doesn't show classic Mongolian script correctly.

Reproducible: Always

Comment 1

7 years ago
This is probably a duplicate of Bug 231463.

I'd love to see Firefox be the first Free Software that supports Mongolian...
If harfbuzz has support, can we fix this by changing the value of gfx.font_rendering.harfbuzz.scripts?
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
(Reporter)

Comment 3

7 years ago
Harfbuzz supports classic Mongolian a year ago. See here: https://bugs.freedesktop.org/show_bug.cgi?id=32274

At that time, the shaping worked in firefox. See here: https://github.com/tugstugi/mongolian-script/raw/master/misc/minefield-harfbuzz-mongolian.png

But now, it doesn't work. Setting gfx.font_rendering.harfbuzz.scripts doesn't help anymore.
(Reporter)

Updated

7 years ago
Depends on: 695857
(Reporter)

Comment 4

6 years ago
Now, the firefox is shaping the classic Mongolian correctly. But we have to set  gfx.font_rendering.harfbuzz.scripts = 23 on Linux and  gfx.font_rendering.harfbuzz.scripts = 87 on Mac.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.