Closed Bug 665378 Opened 8 years ago Closed 8 years ago

Intermittent browser_inlinesettings.js | File picker mode should be open file - Got undefined, expected 0 followed by breaking browser_install.js and browser_list.js and browser_sorting.js by not cleaning up

Categories

(Toolkit :: Add-ons Manager, defect)

All
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla7

People

(Reporter: philor, Assigned: darktrojan)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files, 3 obsolete files)

http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308512631.1308514095.20380.gz
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2011/06/19 12:43:51
s: talos-r3-fed-035

TEST-PASS | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_inlinesettings.js | Color picker should have initial value
ReferenceError: inputChanged is not definedTEST-PASS | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_inlinesettings.js | Color picker should have updated value
TEST-PASS | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_inlinesettings.js | Color pref should have been updated
TEST-PASS | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_inlinesettings.js | Label value should be empty
NEXT ERROR ReferenceError: inputChanged is not definedTEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_inlinesettings.js | File picker mode should be open file - Got undefined, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_inlinesettings.js | Label value should match file chosen - Got , expected /tmp/tmplcqHAF
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_inlinesettings.js | Console message: [JavaScript Error: "uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch2.getCharPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_inlinesettings.js :: <TOP_LEVEL> :: line 218"  data: no]"]
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_inlinesettings.js | Longer timeout required, waiting longer...  Remaining timeouts: 1
NEXT ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_inlinesettings.js | Test timed out
(here is where registerCleanupFunction() would have saved you from breaking anyone else)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be only one item in the list - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be no items in the list - Got 1, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be only one item in the list - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be no items in the list - Got 1, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be only one item in the list - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be no items in the list - Got 1, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be only one item in the list - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be no items in the list - Got 1, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be no items in the list - Got 1, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be no items in the list - Got 1, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be only one item in the list - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be only one item in the list - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be only one item in the list - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be only one item in the list once the update has started - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be only one item in the list - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be only one item in the list - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be only one item in the list - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be only one item in the list - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be no items in the list - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_install.js | Should be no items in the list - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_list.js | Should be seven add-ons installed - Got 8, expected 7
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_list.js | Should be seven add-ons installed - Got 8, expected 7
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_list.js | Should be seven add-ons installed - Got 8, expected 7
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_sorting.js | Should have seen the right order - Got ["test2@tests.mozilla.org", "test4@tests.mozilla.org", "test3@tests.mozilla.org", "test5@tests.mozilla.org", "inlinesettings1@tests.mozilla.org", "test1@tests.mozilla.org", "test7@tests.mozilla.org", "test8@tests.mozilla.org", "test6@tests.mozilla.org", "test10@tests.mozilla.org", "test9@tests.mozilla.org", "test11@tests.mozilla.org", "test13@tests.mozilla.org", "test12@tests.mozilla.org", "test14@tests.mozilla.org", "test15@tests.mozilla.org", "test17@tests.mozilla.org", "test19@tests.mozilla.org", "test16@tests.mozilla.org", "test20@tests.mozilla.org", "test18@tests.mozilla.org"], expected ["test2@tests.mozilla.org", "test4@tests.mozilla.org", "test3@tests.mozilla.org", "test5@tests.mozilla.org", "test1@tests.mozilla.org", "test7@tests.mozilla.org", "test8@tests.mozilla.org", "test6@tests.mozilla.org", "test10@tests.mozilla.org", "test9@tests.mozilla.org", "test11@tests.mozilla.org", "test13@tests.mozilla.org", "test12@tests.mozilla.org", "test14@tests.mozilla.org", "test15@tests.mozilla.org", "test17@tests.mozilla.org", "test19@tests.mozilla.org", "test16@tests.mozilla.org", "test20@tests.mozilla.org", "test18@tests.mozilla.org"]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_sorting.js | Should have seen the right order - Got ["test5@tests.mozilla.org", "inlinesettings1@tests.mozilla.org", "test3@tests.mozilla.org", "test1@tests.mozilla.org", "test2@tests.mozilla.org", "test4@tests.mozilla.org", "test10@tests.mozilla.org", "test9@tests.mozilla.org", "test8@tests.mozilla.org", "test6@tests.mozilla.org", "test7@tests.mozilla.org", "test12@tests.mozilla.org", "test14@tests.mozilla.org", "test15@tests.mozilla.org", "test13@tests.mozilla.org", "test11@tests.mozilla.org", "test20@tests.mozilla.org", "test17@tests.mozilla.org", "test18@tests.mozilla.org", "test19@tests.mozilla.org", "test16@tests.mozilla.org"], expected ["test5@tests.mozilla.org", "test3@tests.mozilla.org", "test1@tests.mozilla.org", "test2@tests.mozilla.org", "test4@tests.mozilla.org", "test10@tests.mozilla.org", "test9@tests.mozilla.org", "test8@tests.mozilla.org", "test6@tests.mozilla.org", "test7@tests.mozilla.org", "test12@tests.mozilla.org", "test14@tests.mozilla.org", "test15@tests.mozilla.org", "test13@tests.mozilla.org", "test11@tests.mozilla.org", "test20@tests.mozilla.org", "test17@tests.mozilla.org", "test18@tests.mozilla.org", "test19@tests.mozilla.org", "test16@tests.mozilla.org"]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_sorting.js | Should have seen the right order - Got ["test4@tests.mozilla.org", "test2@tests.mozilla.org", "test1@tests.mozilla.org", "test3@tests.mozilla.org", "inlinesettings1@tests.mozilla.org", "test5@tests.mozilla.org", "test7@tests.mozilla.org", "test6@tests.mozilla.org", "test8@tests.mozilla.org", "test9@tests.mozilla.org", "test10@tests.mozilla.org", "test11@tests.mozilla.org", "test13@tests.mozilla.org", "test15@tests.mozilla.org", "test14@tests.mozilla.org", "test12@tests.mozilla.org", "test16@tests.mozilla.org", "test19@tests.mozilla.org", "test18@tests.mozilla.org", "test17@tests.mozilla.org", "test20@tests.mozilla.org"], expected ["test4@tests.mozilla.org", "test2@tests.mozilla.org", "test1@tests.mozilla.org", "test3@tests.mozilla.org", "test5@tests.mozilla.org", "test7@tests.mozilla.org", "test6@tests.mozilla.org", "test8@tests.mozilla.org", "test9@tests.mozilla.org", "test10@tests.mozilla.org", "test11@tests.mozilla.org", "test13@tests.mozilla.org", "test15@tests.mozilla.org", "test14@tests.mozilla.org", "test12@tests.mozilla.org", "test16@tests.mozilla.org", "test19@tests.mozilla.org", "test18@tests.mozilla.org", "test17@tests.mozilla.org", "test20@tests.mozilla.org"]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_sorting.js | Should have seen the right order - Got ["test2@tests.mozilla.org", "test4@tests.mozilla.org", "test3@tests.mozilla.org", "test5@tests.mozilla.org", "inlinesettings1@tests.mozilla.org", "test1@tests.mozilla.org", "test7@tests.mozilla.org", "test8@tests.mozilla.org", "test6@tests.mozilla.org", "test10@tests.mozilla.org", "test9@tests.mozilla.org", "test11@tests.mozilla.org", "test13@tests.mozilla.org", "test12@tests.mozilla.org", "test14@tests.mozilla.org", "test15@tests.mozilla.org", "test17@tests.mozilla.org", "test19@tests.mozilla.org", "test16@tests.mozilla.org", "test20@tests.mozilla.org", "test18@tests.mozilla.org"], expected ["test2@tests.mozilla.org", "test4@tests.mozilla.org", "test3@tests.mozilla.org", "test5@tests.mozilla.org", "test1@tests.mozilla.org", "test7@tests.mozilla.org", "test8@tests.mozilla.org", "test6@tests.mozilla.org", "test10@tests.mozilla.org", "test9@tests.mozilla.org", "test11@tests.mozilla.org", "test13@tests.mozilla.org", "test12@tests.mozilla.org", "test14@tests.mozilla.org", "test15@tests.mozilla.org", "test17@tests.mozilla.org", "test19@tests.mozilla.org", "test16@tests.mozilla.org", "test20@tests.mozilla.org", "test18@tests.mozilla.org"]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_sorting.js | Should have seen the right order - Got ["test1@tests.mozilla.org", "inlinesettings1@tests.mozilla.org", "test5@tests.mozilla.org", "test3@tests.mozilla.org", "test4@tests.mozilla.org", "test2@tests.mozilla.org", "test9@tests.mozilla.org", "test10@tests.mozilla.org", "test6@tests.mozilla.org", "test8@tests.mozilla.org", "test7@tests.mozilla.org", "test15@tests.mozilla.org", "test14@tests.mozilla.org", "test12@tests.mozilla.org", "test13@tests.mozilla.org", "test11@tests.mozilla.org", "test18@tests.mozilla.org", "test20@tests.mozilla.org", "test16@tests.mozilla.org", "test19@tests.mozilla.org", "test17@tests.mozilla.org"], expected ["test1@tests.mozilla.org", "test5@tests.mozilla.org", "test3@tests.mozilla.org", "test4@tests.mozilla.org", "test2@tests.mozilla.org", "test9@tests.mozilla.org", "test10@tests.mozilla.org", "test6@tests.mozilla.org", "test8@tests.mozilla.org", "test7@tests.mozilla.org", "test15@tests.mozilla.org", "test14@tests.mozilla.org", "test12@tests.mozilla.org", "test13@tests.mozilla.org", "test11@tests.mozilla.org", "test18@tests.mozilla.org", "test20@tests.mozilla.org", "test16@tests.mozilla.org", "test19@tests.mozilla.org", "test17@tests.mozilla.org"]
Attached patch fix? (obsolete) — Splinter Review
There's something odd about that colorpicker that's causing this. It's not the ReferenceError but I've fixed that anyway.

I can reproduce the failures by removing the setTimeout after the colorpicker tests, so I've rearranged the test and put the colorpicker last.
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attached patch fix diff with -w (obsolete) — Splinter Review
The other patch is mostly whitespace changes so this is the same thing with -w.
Attachment #540354 - Flags: review?(dtownsend)
Thanks Geoff for picking this up!

One question though: why is the 1200ms timeout necessary here?
(In reply to comment #8)
> Thanks Geoff for picking this up!
> 
> One question though: why is the 1200ms timeout necessary here?

I'm checking that the menulist's selected item changes twice by typing 'b', pause, 'c'. I'd much rather use VK_DOWN but it doesn't work on Mac. The second test isn't strictly necessary, but all the other tests in this set test two changes so I kept it. I don't mind scrapping it if you want.
(In reply to comment #11)
> (In reply to comment #8)
> > Thanks Geoff for picking this up!
> > 
> > One question though: why is the 1200ms timeout necessary here?
> 
> I'm checking that the menulist's selected item changes twice by typing 'b',
> pause, 'c'. I'd much rather use VK_DOWN but it doesn't work on Mac. The
> second test isn't strictly necessary, but all the other tests in this set
> test two changes so I kept it. I don't mind scrapping it if you want.

so the timeout isn't necessary? Let's get rid of it then
(In reply to comment #13)
> (In reply to comment #11)
> > (In reply to comment #8)
> > > Thanks Geoff for picking this up!
> > > 
> > > One question though: why is the 1200ms timeout necessary here?
> > 
> > I'm checking that the menulist's selected item changes twice by typing 'b',
> > pause, 'c'. I'd much rather use VK_DOWN but it doesn't work on Mac. The
> > second test isn't strictly necessary, but all the other tests in this set
> > test two changes so I kept it. I don't mind scrapping it if you want.
> 
> so the timeout isn't necessary? Let's get rid of it then

Yeah, keypress events are dispatched synchronously, so there is no need to wait for anything.
Attached patch fix diff with -w (obsolete) — Splinter Review
(In reply to comment #14)
> Yeah, keypress events are dispatched synchronously, so there is no need to
> wait for anything.

It's not that - if I don't pause before c is pressed it won't change to the item starting with c, because the item starting with b is the best match for 'bc'. If you get what I mean.

Anyway, it's not important to test that here so I've binned it.
Attachment #540353 - Attachment is obsolete: true
Attachment #540354 - Attachment is obsolete: true
Attachment #540354 - Flags: review?(dtownsend)
Attachment #541344 - Flags: review?(dtownsend)
Comment on attachment 541344 [details] [diff] [review]
fix diff with -w

Review of attachment 541344 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/mozapps/extensions/test/browser/addons/browser_inlinesettings1/options.xul
@@ +16,3 @@
>    <setting pref="extensions.inlinesettings1.file" type="file" title="File"/>
>    <setting pref="extensions.inlinesettings1.directory" type="directory" title="Directory"/>
> +  <setting pref="extensions.inlinesettings1.color" type="color" title="Color"/>

Is this rearrangement still necessary?
Attached patch fix diff with -wSplinter Review
(In reply to comment #27)
> Is this rearrangement still necessary?

No it isn't, but your comment has helped me figure out what's actually going wrong. It's not the timeouts or the mockFilePicker, it's the colour picker not closing before the next test is run.

*sound of hand hitting forehead*

I've also made the test continue to the finish and clean up if there's a problem here again.
Attachment #541344 - Attachment is obsolete: true
Attachment #541344 - Flags: review?(dtownsend)
Attachment #542376 - Flags: review?(dtownsend)
Comment on attachment 542376 [details] [diff] [review]
fix diff with -w

Review of attachment 542376 [details] [diff] [review]:
-----------------------------------------------------------------

Looks much nicer
Attachment #542376 - Flags: review?(dtownsend) → review+
Attached patch fixSplinter Review
Keywords: checkin-needed
Landed on inbound.
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/537b9c8a2d68
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla7
Marking as verified fixed based on check-in and no more test failures.
Status: RESOLVED → VERIFIED
Hardware: x86 → All
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.