Last Comment Bug 665391 - Remove unused variable maiAtkHyperlink from nsMaiHyperlink.cpp getUriCB()
: Remove unused variable maiAtkHyperlink from nsMaiHyperlink.cpp getUriCB()
Status: VERIFIED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla7
Assigned To: Ed Morley [:emorley]
:
: alexander :surkov
Mentors:
: 458711 (view as bug list)
Depends on:
Blocks: buildwarning 424264
  Show dependency treegraph
 
Reported: 2011-06-19 15:46 PDT by Ed Morley [:emorley]
Modified: 2011-09-01 00:35 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove unused variable (889 bytes, patch)
2011-06-19 16:42 PDT, Ed Morley [:emorley]
surkov.alexander: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-06-19 15:46:29 PDT
accessible/src/atk/nsMaiHyperlink.cpp:218:22: warning: unused variable 'maiAtkHyperlink'

http://mxr.mozilla.org/mozilla-central/source/accessible/src/atk/nsMaiHyperlink.cpp#218

No longer used since bug 424264:
http://hg.mozilla.org/mozilla-central/diff/cb073c147f53/accessible/src/atk/nsMaiHyperlink.cpp
Comment 1 Ed Morley [:emorley] 2011-06-19 16:42:36 PDT
Created attachment 540357 [details] [diff] [review]
Remove unused variable
Comment 2 Ed Morley [:emorley] 2011-06-20 09:25:24 PDT
http://dev.philringnalda.com/tbpl/?tree=Try&rev=0f7f8aa6e296
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2011-06-21 12:14:32 PDT
http://hg.mozilla.org/mozilla-central/rev/02e71c0a1bc0
Comment 4 Ed Morley [:emorley] 2011-07-07 10:55:25 PDT
*** Bug 458711 has been marked as a duplicate of this bug. ***
Comment 5 Simona B [:simonab ] 2011-08-31 06:42:17 PDT
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0

I visually inspected the code changes and maiAtkHyperlink variable is removed from nsMaiHyperlink.cpp:
http://hg.mozilla.org/mozilla-central/file/922f27baed98/accessible/src/atk/nsMaiHyperlink.cpp

Is there a test case to verify this manually or is it enough to mark this as Verified Fixed?

Thanks!
Comment 6 alexander :surkov 2011-08-31 06:50:37 PDT
(In reply to Simona B [QA] from comment #5)
> Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0
> 
> I visually inspected the code changes and maiAtkHyperlink variable is
> removed from nsMaiHyperlink.cpp:
> http://hg.mozilla.org/mozilla-central/file/922f27baed98/accessible/src/atk/
> nsMaiHyperlink.cpp
> 
> Is there a test case to verify this manually or is it enough to mark this as
> Verified Fixed?

There's no test case. Visual confirmation is a way to go. So feel free mark verified.
Comment 7 Simona B [:simonab ] 2011-09-01 00:35:18 PDT
Based on Comment 6 marking this as VERIFIED FIXED.

Thanks alexander!

Note You need to log in before you can comment on or make changes to this bug.