Last Comment Bug 665405 - Dehydra test failure with gcc 4.6
: Dehydra test failure with gcc 4.6
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Rewriting and Analysis (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: ---
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-19 19:07 PDT by Mike Hommey [:glandium]
Modified: 2011-06-20 18:26 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (352 bytes, patch)
2011-06-19 19:07 PDT, Mike Hommey [:glandium]
taras.mozilla: review+
Details | Diff | Review

Description Mike Hommey [:glandium] 2011-06-19 19:07:25 PDT
Created attachment 540375 [details] [diff] [review]
Patch

python unit_test_harness.py dehydra "/usr/bin/g++-4.6"
............................................x.........................
Test Failure: 
    Test command: /usr/bin/g++-4.6 -c -fplugin=../gcc_dehydra.so -o /dev/null -fplugin-arg-gcc_dehydra-script=test_static_func.js test_static_func.cc
    Failure msg: Expected 'OK' output; got '{anonymous}::nst()true'

This is due to <unnamed> having been renamed to {anonymous}, apparently.

Note You need to log in before you can comment on or make changes to this bug.