make Byob ready for Firefox 5 Builds

RESOLVED FIXED

Status

Websites Graveyard
byob.mozilla.com
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
since Firefox 5 is nearly out, we should also make BYOB ready for Firefox 5. Not sure whats needed for this, so cc'ing people knowing what we need here :)

Comment 1

6 years ago
The two areas that need to be addressed firefox 4/5 compatibility are:

- update of the Addon installer to address the changes introduced with Firefox 4 (https://developer.mozilla.org/en/Addons/Add-on_Manager) Appcoast is looking at it, and hopes to have something ready to go end-of-week.
- update of the repack scripts to reflect the new location of repack files in the windows installer from "nonlocalized" to "core". I'll file a patch for that shortly.

These will allow us to get up and running, but near-term we need to also get rid of personas plus and use preferences only for specifying a default persona, update the repack script to one based on what coop's using in production, and finish the work started with the repacks being moved to the minis and automagic signing implemented, which bear is going to be working on.

Tomcat, maybe we can work on a product page for BYOB that outlines new work that needs to be done.
(Reporter)

Comment 2

6 years ago
(In reply to comment #1)

> 
> Tomcat, maybe we can work on a product page for BYOB that outlines new work
> that needs to be done.

sounds like a cool idea. How about filing a tracking bug for this new changes too (or moving this bug into a tracking bug)
(Reporter)

Comment 3

6 years ago
and will take the work with the product page suggested by kev
(Reporter)

Updated

6 years ago
Depends on: 666909
(Reporter)

Updated

6 years ago
Duplicate of this bug: 636508

Updated

6 years ago
Depends on: 668180

Updated

6 years ago
Depends on: 668181
(Reporter)

Updated

6 years ago
Depends on: 671511

Comment 5

6 years ago
This can be closed now. byob is Firefox 9 ready.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.