Closed Bug 665671 Opened 11 years ago Closed 10 years ago

Bookmarks lost when upgrading from SM 2.0.X to 2.1

Categories

(SeaMonkey :: Bookmarks & History, defect)

SeaMonkey 2.1 Branch
x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 673474

People

(Reporter: dsmutil, Unassigned)

Details

(Whiteboard: [2012 Fall Equinox])

I just upgraded from SeaMonkey 2.0.X (I think 2.0.13 but I'm not certain) to the latest release 2.1 (build 20110608). My bookmarks were held in bookmarks.html previously but it doesn't seem they were imported automatically. I searched in places.sqlite under moz_bookmarks and moz_places for a few select bookmarks in the html file but was unsuccessful.

I did have Sync/Weave installed before and the bookmarkbackups folder has entries that mentions "sync/children" but there are no bookmarks in either file in that folder.

This may be a dupe to bug 637568 but that is for 2.1b and this is for a release version, so going forward.
You can manually import your bookmarks.html file.
From the Tools->Import HTML
Then: Import bookmarks from
(*) File.

bookmarks.html import is only done once per profile. If you've ever run SeaMonkey 2.1b on your 2.0 profile then places.sqlite is flagged so that it is not imported again (and again, and again).
I've never run version 2.1b. The only thing unusual is running the FF Sync add-on.
Even stranger then because you would see your Firefox bookmarks in 2.1 with Sync running on both Firefox and SeaMonkey.
No Firefox involved at all. I just installed Sync to test it and thought about trying it at work to see what works but never got around to it.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: [2012 Fall Equinox]
Duplicate of bug: 673474
You need to log in before you can comment on or make changes to this bug.