Last Comment Bug 665704 - dragleave not fired when dragging outside window
: dragleave not fired when dragging outside window
Status: RESOLVED DUPLICATE of bug 656164
:
Product: Core
Classification: Components
Component: Drag and Drop (show other bugs)
: unspecified
: All All
: -- normal with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-20 14:15 PDT by Gopal Sharma
Modified: 2016-02-24 12:08 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test file. (1.32 KB, text/html)
2011-06-20 14:16 PDT, Gopal Sharma
no flags Details

Description Gopal Sharma 2011-06-20 14:15:55 PDT
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

When you drag a file into a window, dragenter fires as expected, however, when you drag it outside the window, drag leave does not. If you hit the escape key, dragleave is fired. 

Reproducible: Always

Steps to Reproduce:
1. Open attached index.html file.
2. Drag a file from Finder into the window. If you check the console log, you will see dragenter and dragover are being filed as expected. 
3. Without letting go, drag the file outside the window. dragleave is not fired.

Actual Results:  
dragleave is not fired.

Expected Results:  
dragleave should be fired.
Comment 1 Gopal Sharma 2011-06-20 14:16:57 PDT
Created attachment 540586 [details]
Test file.
Comment 2 Marcia Knous [:marcia - use ni] 2011-06-20 16:02:56 PDT
Gopal: I have Console turned on, but I am not seeing the the drag events logged to the console. Is there something special I have to do?
Comment 3 Gopal Sharma 2011-06-20 16:08:30 PDT
Marcia: Not that I know of... I'm just using console.log() to log the messages. You should be seeing them in Firebug's console or in the Web Console (Cmd + Shift + K).
Comment 4 Steven Michaud [:smichaud] (Retired) 2011-06-20 16:18:30 PDT
Does this problem also happen on other versions of OS X than 10.7
(like 10.6)?

Does it also happen on other OSes (like Windows or Linux)?

Does it happen with a current trunk nightly
(e.g. ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/firefox-7.0a1.en-US.mac.dmg)?
Comment 5 Gopal Sharma 2011-06-20 16:35:18 PDT
I am able to reproduce the problem on the following platform/browser combinations (I have not tried others):

Mac OS X 10.7 + Firefox 4 (the build listed above)
Mac OS X 10.7 + Nightly (the one you specified)

Mac OS X 10.6 + Firefox 4 (the build listed above)
Mac OS X 10.6 + Nightly (the one you specified)

Windows 7 + Firefox 4 (the build listed above)
Comment 7 Steven Michaud [:smichaud] (Retired) 2011-06-21 08:54:03 PDT
I've confirmed this (in a recent nightly) on OS X (10.6 and 10.7),
Windows and Linux.
Comment 8 (mostly gone) XtC4UaLL [:xtc4uall] 2011-06-21 15:52:44 PDT
Hmm, I see dragleave on[object HTMLDivElement] Entries doing the last Step both on Trunk and on GC 14 on WinXP.
Comment 9 Steven Michaud [:smichaud] (Retired) 2011-06-21 16:46:26 PDT
The testcase is misleading.  The problem doesn't happen with the "This is my dropzone ..." object.  It does happen dragging into and out of the rest of the page (from the desktop to that part of the page and back again).
Comment 10 Steven Michaud [:smichaud] (Retired) 2011-06-21 16:55:48 PDT
> The problem doesn't happen with the "This is my dropzone ..."
> object.  It does happen dragging into and out of the rest of the
> page (from the desktop to that part of the page and back again).

Actually it *does* happen with the "This is my dropzone ..." object,
but only if you drag directly from the desktop onto and off of that
object.

And (as best I can tell) the problem doesn't happen with either part
of the page if you drag over a scrollbar.
Comment 11 Steven Michaud [:smichaud] (Retired) 2011-06-23 14:21:33 PDT
See also bug 656164.
Comment 12 Andrew Jacobs 2011-10-06 17:32:15 PDT
I can still repro this bug on Windows 7 + Firefox 7.0.1.  Dragexit and dragleave are never triggered on the window, document, or fullscreen DOM element.
Comment 13 Kohei Yoshino [:kohei] 2016-02-24 12:08:36 PST

*** This bug has been marked as a duplicate of bug 656164 ***

Note You need to log in before you can comment on or make changes to this bug.