Closed Bug 666012 Opened 11 years ago Closed 11 years ago

Build and deploy Runfield snippet to Aurora channel - 2 day test

Categories

(Snippets Graveyard :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: lforrest, Assigned: cmore)

Details

Attachments

(2 files)

Attached image Screenshot
In order surprise and delight the early adopters running Aurora, as well as to educate them about how innovative it is, we'd like to serve those users a mini version of Runfield through the snippet service. 

This will run for two days in en-US only to test it out and see how people respond.

Final Copy:
Play Runfield and experience the latest HTML5 innovations in Aurora.

Music off by default. Screenshot attached. 

This is a part of the larger "Add HTML5 Awesomeness to snippets" Project. 

Chris - Next step is to finalize snippet compression and load new final copy above and then I can help push live in production. 

Timing: Let's shoot to get this live Wed of this week.
Assignee: nobody → chrismore.bugzilla
I've sent Raymond the latest version of the compressed html file and he is reviewing it. I've CC'd him on this bug. The HTML file is now 844k, which is better then 2.5MB when we started.
The latest code is and client matching rule are set in stage:

Laura: You can copy/paste the code from this Snippet to production. When you copy/paste, give it time as it beach ball will show up for 15-30 seconds while copying/pasting.

https://snippets.stage.mozilla.com/admin/homesnippets/snippet/2671/

Raymond confirmed that the Snippet does set up CPU, but we ran our tests and it did not crash the browser. Seeing that this is the Aurora channel, visitors know they are getting experimental products.

I used the Snippet Switcher add-on and changed my channel to aurora, and locale to en-US, and the Runfield Snippet loaded.

Good to go!
Two adjustments had to be made to Runfield to get it to function as a Snippet. The size had to be reduced to a 3rd instead of a half because of the percentage width of the Snippets Div. Also, the space key input had to be disabled because of the ability to type in search queries into the Google search box.
Comments on twitter:

http://twitter.com/#!/manat/statuses/84904776571166721 (positive)

http://twitter.com/#!/alina_mierlus/statuses/85117007778947072 (positive)

http://twitter.com/#!/emperium666/status/85325615586217984 (positive)

Comments on Input:

http://input.mozilla.com/en-US/opinion/2167783 (positive)

http://input.mozilla.com/en-US/opinion/2169985 (negative)

Overall, I think this was a good test of HTML5 and we learned a lot about how to make this work within the constrains of a a Snippet. We will want to make more simple games and demos in the future with a smaller payload. We will need to coordinate with IT if and when we want to launch an HTML5 Snippet to an audience larger then Aurora+en-US.
Well said, Chris! Thanks for posting those results. 

I agree, this was a successful first round of introducing engaging and interesting snippet content to our users. From here, we can continue to serve the Runfield snippet to the Aurora channel off and on for a couple of weeks. We'll also continue to work on other dynamic snippets, like Persona Preview, and Add-on Install. 

Closing this bug.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Component: Snippets → General
Product: Mozilla Services → Snippets
Status: RESOLVED → VERIFIED
Product: Snippets → Snippets Graveyard
You need to log in before you can comment on or make changes to this bug.