Last Comment Bug 666047 - GCLI completer text doesn't line up with the inputter text
: GCLI completer text doesn't line up with the inputter text
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on: 666334
Blocks: GCLI-ENABLE
  Show dependency treegraph
 
Reported: 2011-06-21 15:05 PDT by Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7]
Modified: 2011-06-23 13:30 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Example of the mis-alignment (5.85 KB, image/png)
2011-06-21 15:05 PDT, Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7]
no flags Details
Hacky patch to fix the mis-alignment (400 bytes, patch)
2011-06-21 16:18 PDT, Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7]
no flags Details | Diff | Splinter Review
Example of how the mis-alignment is fixed (at least on my machine) (5.12 KB, image/png)
2011-06-21 16:22 PDT, Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7]
no flags Details
New patch (474 bytes, text/plain)
2011-06-21 18:30 PDT, Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7]
jwalker: feedback+
Details

Description Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7] 2011-06-21 15:05:26 PDT
Created attachment 540906 [details]
Example of the mis-alignment
Comment 1 Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7] 2011-06-21 16:18:07 PDT
Created attachment 540923 [details] [diff] [review]
Hacky patch to fix the mis-alignment

Joe, this fixes the issue on my machine, but I am not sure it would work on all machines across the board. What would be a better way to fix this problem?
Comment 2 Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7] 2011-06-21 16:22:06 PDT
Created attachment 540925 [details]
Example of how the mis-alignment is fixed (at least on my machine)
Comment 3 Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7] 2011-06-21 17:47:02 PDT
Just realized that this patch wrecks the existing jsterm's text alignment.
Comment 4 Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7] 2011-06-21 18:30:33 PDT
Created attachment 540941 [details]
New patch

It seems that the reason the font alignment was messed up for GCLI but not jsterm is because jsterm uses a textbox element for the completer's node, but GCLI uses a div. I looked in to the styles that are applied to textboxes by default and it turns out that they have some margin by default!
Comment 5 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-06-22 04:57:24 PDT
Comment on attachment 540941 [details]
New patch


It seems like a standard for CSS files to not have the tag name in there. i.e. s/div.jsterm/.jsterm/ and I know from previous work that the CSS files sometimes get significant scrutiny, so it's probably worth fixing.

We should (but to-date I have not) make similar changes in pinstripe/winstripe and gnomestripe. I'm guessing you're on a mac (pinstripe) so you won't easily be able to test the other configs anyway. I've vagely planned on doing that towards the end of the cycle (I've got a PC on order, which will help too)
Comment 6 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-06-22 04:59:30 PDT
Comment on attachment 540941 [details]
New patch

f+ the patch when the div part of the selector is gone.
Comment 7 Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7] 2011-06-22 14:45:09 PDT
Can't happen until https://bugzilla.mozilla.org/show_bug.cgi?id=666334 is completed because the div prefix is required b/c of the textbox vs. div default style issues that I mention above.

Note You need to log in before you can comment on or make changes to this bug.