Last Comment Bug 666057 - The GCLI repo contains built files. Should it?
: The GCLI repo contains built files. Should it?
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Joe Walker [:jwalker] (needinfo me or ping on irc)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-21 15:19 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-01-13 10:37 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-06-21 15:19:02 PDT
We're being more careful about reviewing individual changes, so it's going to get to be a pain having extra mess around.
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-06-21 15:21:16 PDT
Maybe we could have a separate branch with them in?

Or maybe we should tackle the root cause - i.e. an easy way to deploy - so equip the Makefile with a "built file scp system"
Comment 2 Nick Fitzgerald [:fitzgen] [⏰PDT; UTC-7] 2011-06-21 16:30:15 PDT
It bugs me too because it makes `git grep <foo>` slightly less useful. I need to do `git grep <foo> | grep -v define`. Plus, you have to remember to keep the build updated when you commit!

Would it be so horrible to just require node if you want to build the jsm and friends?
Comment 3 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-06-22 05:01:50 PDT
It's me being lazy really - it was an easy way to sync with people.mozilla.com so I could upload https://people.mozilla.com/~jwalker/gcli/build/

rsync will do too.

I'll remove them.

Note You need to log in before you can comment on or make changes to this bug.